Jump to content

Occasional HMI Mismatch


Recommended Posts

I am still experiencing occasional HMI mismatches. The application has been created under Windows 7 and I have upgraded to Unilogic 1.7.62. I also upgraded the OS on my 10" Unistream to the current firmware. This problem happened before the upgrades and is still happening on occasion.

Link to comment
Share on other sites

  • 2 months later...

I too get the HMI mismatch error occasionally. It has been a common re-occurrence on all 3 Unistream panels that I have programmed. The first time it usually occurs is when upgrading the software from the factory version to the current version. This first mis-match is to be expected since the hardware usually ships with a version that is outdated by the time the hardware gets to the user. Once the hardware is updated, this seems to go away as it should but after downloaded a new program several times, occasionally, the HMI mis-match error reoccurs. I have almost always simply downloaded the same program again and the error went away. Please note that this process had nothing to do with upgrading the HMI software to make the error go away, I simply re-initiated the same program download that occurred just before the mis-match error. For some reason this process seems to fix the problem.


I may be wrong about this, but it seems that when the mis-match error shows up after the initial out-of-the-box software upgrade occurs, it is somewhat of a phantom error and is easily cancelled out by repeating the download.

Link to comment
Share on other sites

  • 2 weeks later...

My issue with the mismatches was appartently due to a lot of binary images that would change state at the same time. The images themselves were resized in Unilogic and were quite different than the original image pixel sizes. Unitronics support had me resize the images to the intended size of my application and load them.


Ofir, if your listening..........thus far.......HMI mismatch has not occurred since those changes. Thanks!

Link to comment
Share on other sites

  • 1 year later...
Guest serendepidy

I found the same thing, tried to upload an example program, had to upgrade the firmware, then it wouldnt let me download any new programs until the example program I tried to upload previously was downloaded........


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...