Jump to content

Recommended Posts

Hi,

I am starting a new project on V350 with IOA14A02.

I am simulating 4-20 mA input and trying to use linearization.

X1: D#=819

Y1: D#=0

X2: D#=4095

Y2: D#=10

X=MI 0

Y=MI 20

 

I have no problem with the input MI0 I can see the full range when I change the potentiometer.

BUT MI20 does not show any result.

I am checking older example I have done and that works on the v130 and it seems I have done the exact same thing.

What I am missing?

 

Thanks

Amir

Link to post
Share on other sites

Hi,

Thanks for you quick advice, 

The block does receive power, and the strange thing is that using the math linearization I am getting the problem described above, but if I use variable numeric and use the linearization it does work.

MI 20 is not used elsewhere.

 

??

Link to post
Share on other sites

Hello

 

Also a simple test to see if MI20 is not overwritten somewhere else within the program is to just change it,s value online with Visilogic and see if it keeps the

value that you have last written to it.

If so then at least you know that it,s not overwritten and that the problem is within the linearization function.

 

Regards

 

Henny

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...