Jump to content

Cant connect to plc remotely ?


Recommended Posts

Hey there im new to plc programming and I have tried to make an application witch could control the plc remotely .

Ethernet ethernet = new Ethernet("*REMOTE_IP*", 20256, EthProtocol.TCP, 3, 3000);

Now when im on the same network[same router] as the plc everything goes fine but once I try to reach it from a different network Im getting an exception at this part.


I have opened the 20256 and 20257 ports on the router and it still didnt worked.



any idea what might be wrong ? is there a chance that the plc it self reject the remote connection ?


*PLC model - V1040-T20B


Thanks in advanced

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...