Jump to content

Siemnes Synco 700 & V570 via modbus TCP/IP

Recommended Posts

Hello, everybody!

Has anyone tried to make data connection between SIEMNS SYNCO 700 (ventilation controller) and V570 via MODBUS TCP/IP? I was trying all day, but could'nt figure it out how to connect: set IP adresses manually and other settings, but socket did'nt initialized (tried all of them). Maybe someone had similar system and could share his opinion abot it? Thank you!

Link to comment
Share on other sites

Hello, Emil,

I'm sorry - it's not SYNCO, but SAPHIR (POL63) controller (siemens).. It's used with VENTUS ventilation systems.

Yes, I can ping ventilation controller from PC.

Controller parameters:

Type of connection 10/100Mbit (IEEE 802.3U)

Protocol Modbus TCP/IP

Type Server

Port 502

DHCP mode disabled

That's all I can say for now.. There's no way to check if the listen mode is set or reset, because there's no such option in HMI comm menu..

The controller has webscada and it works fine, when we connect from PC through web broxser by set IP address. But I can't connect to controller from PLC..

Link to comment
Share on other sites

Good news. It seems we are close now.


- change Socket 2 to Master (Socket Init).

- Try to Connect Socket 2 to IP of Saphir.

- If you will receive Connected (SB149 ON) you can try Modbus IP command - according to spec of SAPHIR applied to operand address according to Slave address table of this instrument.

Link to comment
Share on other sites

Thank you a lot:) It was silly ot to use full size editor:)

So here's the snippet of the code I used to connect to SAPHIR. Maybe I do something wrong?

When you say "socket didn't initialize". Do you really mean that "socket didn't connect"?

Check these status bits and post the results.

SB141 should be on

SB142 should be on

SB142 will come on once the socket "initializes"

SB149 will come on once the socket "connects"

SB151 must be ON

What is value of SB167?

Do you have SB168 set to 1?

What is the value of SI147

Make MB151 a normal contact (not positive transition)

In your IP config, your slave address is set to 255. Your device may have a modbus address you need to set this to. A good guess would be 1

Your communication timeout is pretty small (25) try increasing to (100)

Link to comment
Share on other sites

Hi, Emil and Damian,

Now I can give you some feedback, tried today and will try tomorrow, because it was no good..

As Emil suggested, I changed socket 2 to master and tried to connect to IP of SAPHIR - no result.. I tried initialize socket 2 to local port 502 and connect to remote port 502, then I tried to initialize socket 2 to local port 20256 then to 20257 and connect to remote port 502. None of them worked..

As Damian questioned, here are answers;

I can ping and connect to Vision 350, i can ping and connect through browser to SAPHIR. When I connect devices with cable, SB141 and SB142 are ON.

SB151 - ON, SB167 - 0, SB168 - 1, SI147 - 0.

Tried (as shown in MODBUS TCP example) to change to socket 3, but the same results...

No idea what's wrong..

P.S. Maybe someone could suggest what is the best tool to check Modbus TCP connection from PC?

Link to comment
Share on other sites

  • MVP 2023

In answer to your last question, a PC-based Modbus simulator is invaluable for tracking down Modbus problems. None of the good ones are free, however. I've had good luck with this one-

Calta Modbus Simulator (The MDBUS product)

For $180 US, it works great as a master and slave for both serial and TCP/IP. No, I don't get a commission. The demo they offer may be enough to answer your questions.

Joe T.

Link to comment
Share on other sites

Hi Vidmas,

There is no point in continuously trying differnet sockets and different ports. You will save yourself a lot of time by restricting yourself to port 502 and Socket 2.

Can you please send a new screen shot (like you did before) now showing your code with the modifications that were suggested?

What value did you use for a slave address?

It doesn't make sense to me that you have a value of 0 in SI147 if you have SB142 on with the setting we suggested. What is value of SI143 after running the suggested settings?

Are you going through a switch, or are you directly connecting the two devices? If it is a direct connection, are you using a crossover cable?


Link to comment
Share on other sites

Hi Vidmas,

"Technically" you should either be using a crossover cable, or be going through a switch. I tested my V570 connected with a patch cable directly to a different device, and it did work, so it is hard to say if this is part of the problem. It is better to rule it out though.

Your IP settings have all changed since before? Why a subnet of Please change the subnet back to on both the Unitronics and the Ventus and in all the software setup.

So judging by this, your PLC is at and your ventus is a

Somewhere in your Ventus configuration you should be able to set the Slave adress of the unit. This is separate from the IP address. You should find it and make sure it is set to 1.

Link to comment
Share on other sites

Hi, Damian,

The IP settings we use according to building's network, because now we connected ventilation units to scada system using tcp port and manufacturer's webscada (through web browser). All this works fine..

But I still tried to connect to unit with V570, without any results. Cable isn't crossover and there is no switch. Ping goes fine. There's no way (no setting in controllers menu) to set slaves address. No word about it in documentation. I connected to SAPHIR through USB port with SIEMENS software called SAPHIRSCOPE, where all settings can be configured too. But there's too no such setting (I mean slave address). So, with connection to this unit it is still open question. I'll try once again to figure it out as soon I'll be in object..

Link to comment
Share on other sites


Are you able to connect the PLC via Ethernet using any Unitronics software? (VisiLogic , Remote Acces..)

Please make sure that there is no firewall or any antivirus which might block the port you are trying to connect.

Hi Ofir,

If you read above, he has a direct connection between the Unitronics and the controller. There is no PC/switch/firewall etc. in the system. He has already verified communication from the PC since as he stated before it does PING.

Link to comment
Share on other sites


I wrote yesterday, but for some reason it wasn't posted..

I use no crossover cable, there's no switch (I connect PLC and SAPHIR directly). Cable length is about 2-3m. The IP settings I made according to building's, where the ventilation system belongs to. Now we connect to SAPHIR through web browser to manufacturer's webscada and it works fine. In SAPHIR's menu there's no setting like slave address. I connected through USB port using SIEMENS software SAPHIR SCOPE (for configuring ventilation controllers) but there's no such setting too. So there is possibility, that I'm using wrong ID number.

And if we set PLC name (master) , how it is with slave's name? Maybe wrong slave's name is the reason?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...