Jump to content

UniDownloader fails with O/S update on V1210

Recommended Posts

I have been unable to do a full system and application update on a V1210. I have created several different .UDC files for testing, and regardless of whether it tries to update the binary, the  boot, or the O/S, it fails with an error message during the first step of erasing the flash memory. On the HMI, the "status" shows "erasing" with no percent completion. The application file alone updates fine, but not with any one or more of the others. I have run the downloader as administrator.

Everything updates properly from the SD card or from Visilogic.

Versions are as follows...

Visilogic 9.8.31 (build 0); O/S 4.3(05); Boot 2.2(29); Bin Lib 0-3.10(03); Unidownloader 5.0.25

Does anyone have any thoughts on what might be happening? And in a related question, do I need to do this or will the application file update the O/S? My concern is if they update the application onto an older operating system in the panel which is incompatible. The job is in Korea and I am in Chicago, so obviously I need to get this right so the customer can do it without problems.

Thanks in advance

Link to comment
Share on other sites

Not a dumb question at all. I needed to double check, but yes, Visilogic.exe is set to run as administrator (as I recall I had some problems running it until I did that). I routinely update the firmware in my various lab vision units (V350, 430, 570 and 1210) from this computer. I also routinely use SD cards both here and in the field, with files created on this computer. I have not used the UniDownloader very frequently. This PC runs Windows 8.1. I did not try any of this from my laptop with Windows 10, so I think I may do that. Take this computer out of the equation completely.

Link to comment
Share on other sites

Update: I repeated this using a second computer running Windows 10. The download was created on that computer, from the same Visilogic project file. The results were the same. I also tried a creating and downloading a file from a V570 project, and it worked perfectly. So my conclusions so far are that the download creator and UniDownloader seem to be working fine. The problem is not related to the computer or operating system. The only difference between success and failure appears to be the PLC. The V1210 does not work, the V570 does. While the two applications were obviously also different, the problem occurs during V1210 system file downloads, and in fact the V1210 application download works fine.


I also observed that when it fails, the PLC is locked up. You can't even go into boot mode. holding the screen press does nothing.  After cycling the power, then it can be restored by reloading the operating system from the SD card.

Link to comment
Share on other sites

  • MVP 2023

The behaviour sounds just like what happens if you do a normal O/S install by trying through an incorrect connection type, so as Joe says...Creators please.

However, just out of curiosity, does it work ok with previous versions of the programs involved?  An hours worth of trying might get the workaround you need at present.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...