Jump to content

Recommended Posts

I am getting the following error when trying to initialize/go online for the first time with my V570. 


"Communication over TCP/IP could not be established due to one of the following reasons: 

- cable connections are not secure

- incorrect TCP/IP settings (IP address, Protocol type, Port number)

- the connection is currently being used by another application. "


Right now the first net in my main routine is checking SB2, following by Set PLC Name, followed by a TCP/IP - Card Init, (setting IP to, and then a Socket Init (using socket 1, TCP, port 20256, and client set to server [slave]). 

In communication and OS I have tried my connection as both TCP/IP (Call) & TCP/IP (Listen), I am using a favorite with the same name and IP as specified above. 

My local machine IP is set to 

I am connected directly to the ethernet port on the V570 with the V200-19-ET2 ethernet com port

I am trying to "stop-download-reset" to go online and I get the above error consistently.

I'm sure this is a basic question but I have watched all the tutorial videos and read the help files and I believe I am doing everything I am supposed to, any advice would be great!

Link to post
Share on other sites

To go online for the first time you will need to connect via serial or USB. After the program is downloaded and the ethernet parameters are set within the PLC, then you can connect via ethernet.

Also, Socket 1 defaults to Port 20256 and Slave, so you don't need the Socket Init for this (though it doesn't hurt).

It is possible to set up the ethernet via INFO Mode, if that's absolutely necessary.

Link to post
Share on other sites

Hi MattP_Mac,

1.Make ping from your PC to PLC IP. Does PLC answers?

2.Open DOS prompt at your PC and enter "telnet 20256". DOS display will blink, clean and stay black. Is this what you see?

3.Enter PLC info mode and check Socket 1 status. Is it connected?

Share test results.



  • Like 1
Link to post
Share on other sites

See attached command line results.

From INFO Mode:

Ethernet Parameters:

IP Address:; Mask; Gateway:

Socket Status:

Socket 0: 20256: TCP Slave: Initialized and Not Connected

Socket 1: 502: TCP Slave: Initialized and Not Connected 

cmd results.JPG

Link to post
Share on other sites

MattP, INFO Mode is telling you that the IP address is You will not be able to connect to if it doesn't yet exist. You either need to update the IP Address in INFO Mode or download your program via serial or USB first.

Link to post
Share on other sites

Just for clarity, Socket Initialization is not the issue here. MattP is trying to perform the first download of his program into a new PLC. Normally, this should be done via serial or USB, which is why Unitronics includes a USB cable in the box. If absolutely necessary to connect via ethernet for the first time, the user must set the IP parameters in INFO Mode and look up the PLC Name.

Link to post
Share on other sites
  • 1 year later...


I have a similar problem. I get the same error message (210). I tried ping in the command prompt and this seems to be OK (same respons as in the tutorial made by unitronics).
I also went to info mode, the IP addresses are all correct (uploaded via serial) but socket 1 is initialized & not connected.
In ladder I removed the socket initializer, but that did not change a thing.

I am using a SM43-J-R20.

Can anyone help me out?

Thanks in advance.


Link to post
Share on other sites
1 hour ago, Flex727 said:

Post your program and someone will take a look. Also, please provide the Ethernet settings of the computer you're trying to connect with.

Thank you for your quick response.

I have had contact with the technical support and possibly the problem is that I do not have the permission to make this connection (a network blocker could be the issue and I have no administration rights). I will check this and hope this will fix my problem.


Link to post
Share on other sites
  • 8 months later...


I also have an ethernet comms issue. I can enter an IP address of in info mode. My project settings are My card init parameters are However, when power is cycled on the plc the ip address defaults to Any ideas as to why this would be happening?



Link to post
Share on other sites

Please don't duplicate post. This forum is staffed by volunteers, not Unitronics employees for the most part and is moderated. It can sometimes take a few hours for someone to approve the post as we also have real lives and jobs away from this forum. You, appropriately created a new topic and have a couple of responses there already - let's keep the responses there.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...