Jump to content

Using GMX Email Host to Send Emails from PLC

Recommended Posts

I've done some searching but have not found an answer to this particular problem yet.

I have tried configuring my Unitronics PLC to send email, and have followed the instructions for initializing and connecting the socket connection to a gmx email host. However, I have noticed that when I telnet to the mail.gmx.com server through port 465 (the only port I can connect through), I get a connection for only about 20 seconds before it is 'closed by foreign host'. It seems like maybe the port is not correct? I have tried 25 (which does not let me connect) and 465 because I found those ports online.

I think the same thing is happening in the ladder code, because i briefly get a successful indication of connection, but then it gets reset.


Has anyone seen this issue before? I was under the impression that GMX was a validated email host to use with these PLCs, so am I doing something wrong?

Link to comment
Share on other sites

So an update to this. I was able to connect to the gmx web server, but I had to use port 587. The PLC successfully sent several emails after I tested it, but I am getting very inconsistent behavior. Sometimes the email goes through. Sometimes, the socket closes immediately upon starting to send the email. Sometimes (most of the time), I get an error 13 or 15 saying that there was something wrong with my password. I know my password is correct, and I'm not changing anything within the email block when i am running these tests back to back.

Does anyone have experience with these issues?

Link to comment
Share on other sites

  • MVP 2023

Vision controllers do not support Secure Socket Layer (SSL).  It has become almost impossible to find a mail service that lets you get around this anymore. I see you have tried other ports. Do you know if gmx has a way to not use SSL?  Which protocol are you using?

Often a short (0.5s) delay is needed with dealing with Unitronics communications.  I've had much better luck putting a delay in between connecting the socket and calling the email block.

The other thing you can do is set up a local server such as https://www.hmailserver.com/ to send your PLC mails to which can wrap them in SSL and forward them on.

Yes, I know this is a problem with the Visions.  I've personally talked to the Creators about it and there's nothing they can do: the Visions have been around a lot longer than SSL has.  If you really need reliable email you have to step up to a UniStream.

Joe T.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...