Jump to content

Vision 120 comms to Epson LX-350 printer over RS232

Recommended Posts

Good morning. I am trying to print messages using the send protocol from a Vision120 to an epson lx350 dot matrix printer. I have the Com Init command and the protocol config command setup.

I have it wired up correctly (I believe) from the RJ11 to RJ45 to the DB25 adapter to plug into the printer.

This system has worked in the past, I inherited the project from a customer who's controls engineer left, and now I'm stuck on getting the printer to work. I have downloaded the program and HMI config and they are working fine.

Does anyone have experience in something similar to this? Is there something on the printer side I have to do?

Let's assume that I have the communication wiring 100% correct. I still have to verify that again in the morning.

Thanks a lot,

Adam McCormick

Link to comment
Share on other sites

  • MVP 2023

Hi Adam,

Have not done an LX350.

However, I'd first be throwing things at the printer via your PC using any of the serial port software out there like Hercules, to check that it is indeed working as expected via the serial line connections you've done.  And also to check that that command structure works as expected. 

Then check what the PLC is doing by monitoring it's outputs.  Somewhere between these two operations you'll likely find the stumbling block and be able to correct things.  If it has indeed worked in the past, I would initially be suspicious of your total wiring config to the printer.  Extra connections needed onto odd pins is not uncommon, or perhaps it is something as simple as a 2 & 3 switch.  You may even end up needing to use a breakout box to help figure things out.

cheers,   Aus.

Link to comment
Share on other sites

  • MVP 2014

FWIW, a "proper" RJ45 to DB25 convertor isn't a "get out of jail free" card.  It might help hold things together but you still need to know where the pins are going.  As Ausman said, testing is key and the basics are RX, TX and Ground, and turn off hardware handshaking.  If you can't turn off hardware handshaking then a loopback is needed on the handshake lines.

Link to comment
Share on other sites

Thanks a lot guys, turns out it was a poor cable connection.... anti-climactic I know...

I am going RJ11 to RJ45/Ethernet to DB25... I was treating the RJ11 cable as a straight through, but it was in fact a crossover which I didn't realise.

I don't like the application to begin with, sending an RS232 signal to an old dot matrix printer is a little archaic for me but I got it going so thats the important part!

Thanks a lot for the feedback everyone.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...