Jump to content

Recommended Posts

Hello Everyone,

I seemed to have "bricked" Visilogic on my PC.  Was connected/online with a PLC, I shut the lid to my laptop, when I opened the lid my computer was off... not sure why or how it completely shut down but it was definitely off.  Restarted the PC, tried to restart Visilogic and I get the error message below.  Note the file referenced (Current_OPLC.udb) is not present in the specified directory.

I uninstalled / reinstalled Visilogic, tried opening other projects, even tried just opening Visilogic with no project loaded.  I can get it to open by right clicking and running the .exe as administrator, but it still crashes when I try to open any application.

Additional Details:

Windows Pro 10 64 Bit, Visilogic 9.8.31, Vision 130-33-T38 PLC.  Also sent an email to support but as it was late in the day I haven't heard back as of this time.

Any help getting this resolved would be appreciated.


err msg.png

Link to comment
Share on other sites

  • MVP 2023

When you uninstall VisiLogic, make sure ALL the files from the previous VisiLogic installation are deleted (except project files, of course - move them elsewhere). Reboot the computer then install VisiLogic AS ADMINISTRATOR. Then when you run VisiLogic, make sure you run it AS ADMINISTRATOR (every time).

If the problem still exists, then follow the instructions on the error message and contact Unitronics Support (Edit - I see you already did that).

Link to comment
Share on other sites

Ok just uninstalled/reinstalled as administrator.  Still having issues.  I cannot double click any .vlp file and have it open, Visilogic just crashes with the same message as above.

If I open Visilogic as administrator, then do the File/Open and select the file I was working on, I still get a couple of error messages (see below).   If I do File/Open and select any other files they seem to open.

I'm thinking the root cause of this is a corrupted file or key and a dirty uninstall where the file or registry key persists.  Looking at the registry after an uninstall and reboot, it's filled with Uni entries.

As noted above, I already submitted a support email, so hopefully I'll hear back sometime soon.

err msg 2.png

err msg 3.png

Link to comment
Share on other sites

Just tried to restore it prior to when the event occurred, no luck.  Same error message on start up.

Hopefully the support team will have some suggestions.  Hate to think I may have to re-install windows just to get Visilogic working normally again.

Link to comment
Share on other sites

  • MVP 2023

Do you have a backup of the file you were working on? If not, try copying your file to a different location on your hard drive - a location with less subfolder nesting, then try opening it. If you are still getting the error and other projects open fine, then the problem is almost certainly with a corrupted project file, not a problem with your VisiLogic installation.

When working with mission critical files, whether VisiLogic or other software, I always keep daily backups and multiple versions saved. I strongly recommend creating a system to mitigate this type of problem as file corruption can happen at any time and with any software.

Link to comment
Share on other sites


As I understand every time you try to open VisiLogic you get this error message. As Flex mentioned first backup your project file .

Then try the  follwing:

1.      Open Task manager and if VisiLogic process is still running  - End it.

2.       Open C:\Program Files (x86)\Unitronics\Unitronics VisiLogic_C\Data\DB

3.       Delete the file Current_OPLC.udb

4.       Try to open VisiLogic


Link to comment
Share on other sites

Hello Ofir,

I do have backups of the project file, so no worries there.  I checked the DB folder and I do not have a file called Current_OPLC.udb.  I think that may be part of the problem.  I think Visilogic is looking for it, and it's not present.

Reading the error message again, it looks like there's a function in the UnPrHndl1.dll that has  a class call clsDBHandler.  This class has a function OpenConnection that opens a connection to a database.  The error message indicates that it encountered an error opening the connection and notes an unrecognized format.  However the target location where the database should reside does not contain the specified database (Current_OPLC.udb). 

Could someone send me this file.  Maybe if I just drop it into the folder it will satisfy the condition of the OpenConnection function?

Uni Directory.png

err msg.png

Link to comment
Share on other sites

Flex...  no it didn't not include the corrupted file.  The corrupted file would crash either way, so I trashed it.  The issue that remained after the corrupted file was trashed was that if I double click any .vlp file, Visilogic would crash with that error message.  I later discovered that if I opened Visilogic and did a File/Open and navigated it seemed to open ok, but I was never able to simply double click the .vlp file with out it crashing.  But I still wanted to just be able to open by double clicking the file itself.

I think I have it working now.  Here's what I did.

1) Uninstalled Visilogic 9.8.31, looked in Common Files and Program Files and deleted any residual files.

2) Rebooted the PC

3) Installed an old copy of Visilogic 9.7 Build 60.

4) Rebooted the PC

5) Opened one of the example files, and Saved As to the desktop.

6) Closed Visilogic, then double clicked the .vlp file that was saved to the desktop.  (It opened with out crashing)

7) Uninstalled Visilogic 9.7 Build 60.

8) Rebooted the PC

9) Installed Visilogic 9.8.31.

10) Rebooted the PC

11) Double clicked the .vlp file that was saved to the desktop.  (It sill opened with out crashing)

12) Double clicked my backup file for my current project and it opened with out crashing.


Thanks again to all for your support.

Link to comment
Share on other sites

  • 3 years later...
Em 21/05/2017 às 05:23, Ofir disse:


Pelo que entendi, toda vez que você tenta abrir o VisiLogic, você recebe esta mensagem de erro. Como Flex mencionou, primeiro faça o backup do arquivo do projeto.

Em seguida, tente o seguinte:

1. Abra o Gerenciador de tarefas e, se o processo VisiLogic ainda estiver em execução, encerre-o.

2. Abra C: \ Arquivos de programas (x86) \ Unitronics \ Unitronics VisiLogic_C \ Data \ DB

3. Exclua o arquivo Current_OPLC.udb

4. Tente abrir o VisiLogic



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...