Jump to content

V1210 dropping date/time on power cycle

Recommended Posts

I try to make some experiments with RTC on V1040 and V570.
MalSnaize - please try:
1) setup RTC in Visilogic by the present time;
2) Stop the PLC by Visilogic.
3) Power off- on.
4) check in system menu RTC time when the PLC stopped -- RTC correct or not?
5) Run Plc - Check RTC.  



Link to comment
Share on other sites

Hi Ausman - I have to say I was using the direct bit access to do the Init/Reset however I've now used the interface. Same story

No insult my friend; the obvious is obvious to everyone except the operator! Yep I've rechecked its location and orientation and also the tested the voltage which is sitting at 3.3V

Just a point,  - in the (visilogic interface) would I be right in saying the SET RTC value is the PC's RTC and GET RTC VALUES show the PLC?

The former show the correct date/time.


Just trying another full download and reset then will try the battery out but I need to deliver to customer for demo so suspect I wont have time..

Cheers Mal



Link to comment
Share on other sites

HI Kratemel - amazing thinking given I was just typing about the RTC values in the visilogic interface!

I have a full build and download running now so will try that when it finishes.... I'm out of time as I need to leave in 40 minutes to show customer.,

will have to come clean about the clock!



Link to comment
Share on other sites

HI Kratmel - I did your tests, the RTC stayed valid until I did a power cycle.

Ausman - as requested here are some screen shots. I did

1. after program load and set time

2. after visilogic console reset

3. after power cycle

My feeling is that the power cycle is resetting the clock.,


Any thoughts your side?

Cheers Mal

SI Values.PNG

Link to comment
Share on other sites

Wow, really thorough testing!  It looks to me like a hardware fault.  It does happen, out of the thousands of units I have sold, I've seen maybe 2 or 3 with that specific problem.  Before I worked with PLCs I worked with single board computers, and saw similar (rare) problems with them.

My prediction is that no amount of software testing and resetting will fix this.  But happy to be proven wrong (for your sake) ?

Link to comment
Share on other sites

Hi Simon - thanks for your comments - yeah I'd have said the same except that when bought the first V1210 for my client I had the same problem.

Spent ages checking batteries, voltages, etc and finally convinced my supplier to replace the unit.

So this is the same problem with a different V1210 - SOFTWARE! I hear you cry.... but i have the same problem with a blank programme that does nothing.

Same story - set the time, cycle power and the time gets zapped

Its really quite strange (or I am REALLY unlucky having two faulty units)

I've explained the problem to my client and we are now looking at a small UPS solutution - which would be a terrible waste but as a forum we'vce spent a lot of man-hours on this..

Still - I hold my breath for a flash of inspiration from someone.

Link to comment
Share on other sites

5 hours ago, MalSnaize said:

I hold my breath for a flash of inspiration from someone.

I think the final solution is to again go to your supplier with the issue and:

1)  If they already have another unit on hand get them to check straight out of the box whether the problem exists on a virgin unit.  If it doesn't go to point 3.  If it does go to 2.

2).  Get them to source a "fresh" unit...ie not from the same "faulty" batch and when it arrives get them to check again.  Once the problem is definitely not happening on a new unit that has never been touched by your program or anyone else's.....

3).  At your supplier's premises, check again for yourself the issue doesn't exist on the virgin unit, preferably using the computer you have been using all the time.  Then in front of them load your program and see what happens.   If it is ok on just a load, next do a burn, then an upload data as well...checking each time.  In theory your program can't be affecting anything, but by ensuring that a virgin unit is ok and then immediately checking whether your program upsets something on that same unit will be a good pointer for Unitronics to follow up on.

This is the only way I can see of resolving this once and for all, yet still keeping your program "private".  If your program does upset things somehow, then Unitronics needs to know about what you've (inadvertently) done that causes it, because it (perhaps) shouldn't be allowed to happen and whatever the error is needs to be corrected.

cheers, Aus

Link to comment
Share on other sites


I got curious following this,  so I opened up a V1210 I have here, and poked around with a meter. 

This is for a tech to follow.  This is to answer the question - Where is the 3 V going to?

Probably not recommended by Unitronics, but helps troubleshooting the issue.

No External Power connected to the unit.

Battery is on the Power Supply board at the Left.   Meter Common on Battery   - Terminal ( on right side)

Check Battery    + Side is UP  at the terminals on the side    3V?  Yes - OK     No- Bad Connection maybe

 Check   R404 -  Both Sides -  beside the Battery  -  does it have 3V?  Yes - OK     No - Bad traces- or bad resistor - Stop, go to  END

Connector J401 Right side - pin 1 ( arrow)     3V  ?  Yes - OK        J401 has a cable connecting it to the Main Board - White Wires.  No - Go to END

On the Main Board  J1505  Pin 9 ( numbering is reversed on this connector)  3V?  Yes-OK -- -- If No 3 V Here, then the Jumper Cable is suspect- Go to END

On Main Board 6 pin connector  J1506 -  Lower Left Corner  -  Pin with Arrow and Middle pins right side  3V - OK.   If No Voltage, go to END.

 This traces the Battery Voltage onto the main board.  If you  have voltage here, then issue is probably elsewhere.


END    Do not attempt any repairs, the unit may be covered under warranty !!

               Contact  your distributor or Unitronics Support for a Case Number and RMA.


Link to comment
Share on other sites

Thanks Dan, this is just what I was originally on about to check, but without a unit to physically look at, and being unable to have Mal's unit in my hand made it hard.  Hopefully it will help resolve the issue. 

I am still believing it is a fault somewhere, and your info lends weight to this idea as it shows that there are a few connections involved, any of which could be suspect.  Unlike other layouts where it is only insertion pins connecting, or the battery is directly on the board.

cheers, Aus

Link to comment
Share on other sites

HI Ausman, Kratmel and DanT  - a wee update...

I've spoken to my supplier and he's taking the serial number back to Unitronics to see if there is a known issue with that batch. That got me checking and I see that the first unit I had which exhibited the same problem and was replaced turns out to be the one immediately off the  production line (or at least their serial numbers are consecutive).

Am am now leaning to it being a hardware problem (in line your thoughts Simom) - UNLESS someone can point me at a flag that says "clear the clock at power up but not at reset or initialise"

Now that would be magical if there were one and mine was set the wrong way.

DanT thanks for all the trouble you went to tracing the board. I was tempted as I have all the right tools but I'm one of those folks that knows enough to be dangerous so probably best I dont go fiddling inside the box!

As soon as I hear back from supplier I'll post an update


Cheers All!




Link to comment
Share on other sites

Ah Gabriel - 

So Initialise/Reset Clear MI values - keeps SI values

Reset - has no impact on MI values - Keeps SI values

Power Cycle RETAINS MI values but LOSES SI Value (well the clock settings)

So what does that tell me? - something is resetting the clock only at power up but leaving MIs alone.

This has happened with two separate V1210 units but likely out of the same batch given their consecutive serial numbers

It cant be my code as it does this with a totally blank programme.

I feel we are getting closer!


Link to comment
Share on other sites

On 11/16/2017 at 8:30 AM, MalSnaize said:

date time is becoming reset to 1st Jan '06

Maybe it not usefull... and it is not help...:(.

Is it possible to setup date before this date?

I had some issue in CNC machine. Setup date like 00.00.0000 is the solution. But maybe in OPLC it is not possible.


18 hours ago, MalSnaize said:

looking at a small UPS solutution

Maybe it is possible teporary connect the OPLC to GSM or GRPS modem, phone (ect. with embedded RTC)  for synchronise time/date once on power up (if it needed for application).
I'm tryed to find  RTC with  RS232 but it is not present in one device.

Link to comment
Share on other sites

1 hour ago, MalSnaize said:

Power Cycle RETAINS MI values but LOSES SI Value (well the clock settings)

Glad you checked, I thought you had missed my earlier suggestion of doing this.

To me it sounds like either a dud RTC component, or a dud solder or track issue onto the RTC chip's power.  If the RTC is part of the main chip, then the same sort of thing but onto this chip instead.


14 hours ago, Ausman said:

2).  Get them to source a "fresh" unit...ie not from the same "faulty" batch and when it arrives get them to check again.

Definitely, now!

cheers, Aus

Link to comment
Share on other sites

Hi Kratmel - I tried setting the dates to pre-2006.

2005 - ok

2000 - ok

1999 - resulted in 2099

I set to 2000, cycled power and it reverted to 2006. All pretty consistent.

I woldnt be surprised if we find there is a design flaw around the RTC for this batch and there is a floating input somewhere that is casuing the clock to be reset on power cycle.

I'll wait for Unitronics to come back.

On your suggestions of getting external time, the PLC is totally isolated so no network access and no GSM access.

Link to comment
Share on other sites

Hey Aus - sorry, yep I did check but juggling all the great ideas being provided  I missed the specifc response to you.

Agreed - I've escalated to my supplier in Auckland who has promised top followup with Unitronics -

Does anyone know - is there a direct line to Unitronics where I can provide a Serial Number and they can tell me if ther was an issue with the batch?

For me its been 2 out of 2 failures.


Cheers Mal

Link to comment
Share on other sites

Just on your question of a "direct line" - the sort of question you are asking about batch QA issues has both commercial and technical implications, so your supplier/distributor would be the best contact as they can handle both aspects.  It sounds like that is already happening.

In general terms you could email support@unitronics.com (or use the support portal) to communicate the technical issue to Unitronics, but the resolution is likely to still involve your local supplier/distributor.

I hope that helps,


Link to comment
Share on other sites

Yep, understood.  You could email support@unitronics.com, let them know you already have the distributor working on it, and also copy the distributor.  That way you don't get two lots of people working on the same problem and you can get some direct feedback on any technical points that Unitronics may be able to add.

  • Like 1
Link to comment
Share on other sites

Will do guys thanks for guidance.

As an update, I have purchased another unit to see if it does the same thing - my supplier tells me the others in stock do not so If I load my code and it starts doing it then we know its my code.

See my latest fun and games in my post about PLC not being able to communicate with EAX and TO16x

cheers Mal

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...