Jump to content

Password for Administrator could not be changed in UAC


Recommended Posts

Dear all,

I just update the PLC at version 1.22.13; also I update a project that I wrote with the  version 1.19.xx; in this project I have enabled the UAC and insert some users with different levels..also I included a "service" user that has full access...when I try to upload the project I have an error "the password for UniApps Administrator could not be changed" and the download don't works.

I tried to set the "service" user as "super group" but was the same. 

what I'm doing wrong?

Link to comment
Share on other sites

Dear ORSO2001,

I tried to replicate this issue with an application build on 1.19 with UAC with a user set as supper group. I open the application with latest UniLogic 1.22.13 and download it to a UniStream with latest firmware 1.22.9

In my case it worked OK and had no issues downloading the application to the UniStream. I got no error message.

Can you please try downloading an empty application to the UniStream.

After this please try to download your application.

If this does not work, please send the application to support@unitronics.com for review.

Also, please send a screenshot of the error message you get.


Link to comment
Share on other sites

dear Saragani,

sorry...what you mean for unplug and re-plug?...are you talking about during update?...I turned ON my PLC then update without any power missing and without any "error" message...only at the end I have had the highlight that the program uploaded was not "compatible" with the actual version (as usual)...then I tried to upload the update project version...and I have had the "error message"...with other projects, where I don't use UAC, I don't have problem....do I have upload again the last unilogic version?


Link to comment
Share on other sites

  • 4 weeks later...

This is typical behavior after update to the latest version with "improved" UAC (v1.21...)
It even forced me to update my PLCs to the latest project software via USB flash disk rather than usual Ethernet, because it simply didn't work.

Finally I chewed through this. First, you need to disable UAC, then completely remove the old passwords, and finally re-enable UAC and configure it as you wish.
And ,voila, everything works as it should. The "the password for Uniapps Administrator bla, bla, bla..." error is gone.

What I would like to suggest to the Unitronics team - could you do the old password cleanup step for the users automatically upon they're changing to UAC, or at least warn them they'll be in trouble if they didn't do that before proceeding to UAC world.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...