Jump to content

Recommended Posts

HI All - I seem to have all the quirky ones (see my clock issue 

So this issue:

I have a V1210 + Expansion Module + 2xTO16 - all was working fine for client; I recently recovered the set up to develop and implement new features.

On returning the setup today I (for the first time) connected everything up only to find that the expansion module is not communciating with the PLC. :

1. On startup there are some brief flashes on teh comms LED

2. the TO16 just keep flashing.

I loaded my empty test programme which is set up for same hardware config. No change until I did an Iniatlise/Reset (Thanks Ausman) and behold evryting was talking again.

I reloaded my client's software and nope, it will not see the perpheral devices. Tried Initailise reset - still no joy.

I have checked and rechecked the hardware config and it is correct.

Is it possible to somehow disable hardware in code?

The only thing I can think of is that I did update tle PLC OS on Joe's advice (relating to the clock issue); If I update the OS do I need to do something else to ensure compatibility?

Man this PLC is jinxed ! (see my clock issue)

Many thanks in advance of any ideas on this.

Cheers mal

 

Link to post
Share on other sites

Hi Mal, I feel sure that it will be related to the OS update.  But I haven't ever worked with a 1210, so one question to answer before Joe or others chime in is whether you've tried to reload the old OS (you mentioned it was 4.0(19) ) and did this cure things?  And have you  ever had a message during opening your program in Visilogic that it would be updated?

These quirks are one of the reasons Version Swapper exists.  As Flex often says, if it ain't broke,  don't fix it......if a unit is working ok on OS "X" and Visi "Y" etc, then there is no need to update anything.  Use Swapper for any mods needed.    But as you were chasing something unusual you are temporarily exempted from that rule!

cheers, Aus

Link to post
Share on other sites

Hi Ausman yes I I do recall getting a message about updating but I have to say I thought it was relating to the OS rather than the visilogic program.

I ordered a new V1210 which will hopefully arrive today. Hopefully the clock issue will not exist and it will also have the previous OS installed and everything will work.

If not I will use Swapper. Do I need to be online for Swapper to work? (the plC is installed in an isolated location) 

cheers Mal

 

Link to post
Share on other sites

Swapper can work in any connection scenario the version you are using is capable of doing.  I know that's a bit roundabout, but some connection systems have improved over the years.  But given the age of your system, the method you are currently using should be ok.

Bottom is a scrnshot of what I was talking about if you get the update message.  This arises if the program you are opening was actually made in an older version of Visilogic, and an update is deemed necessary by the newer version in use.  It pretty much tells you everything, but especially of note is the bit I have highlighted, which is the version that was used to create the program being opened.  This lets you match up Swapper very easily.  You will need a copy of your original program if using swapper....not the upgraded one. 

If you have never used swapper I suggest you read this post (and topic) thoroughly to get a full understanding of it, and how I implement it:

cheers, Aus

 

Visiupdate.gif.c0ef38c4701c40ed90aeca54a2d0aa0f.gif

Link to post
Share on other sites

This is what the top of my computer desktop looks like. I have all of the versions of VisiLogic that I have used in a row and I move the Version Swapper icon to be under the version currently registered (so I don't accidentally try to open an unregistered version). I NEVER update the firmware of a working PLC in the field. I also place a text box on an easily accessible screen in the PLC program that tells me which version of VisiLogic the program was written with,

image.thumb.png.45c95daa6ef5c9feeae3af8dcf59563a.png

Link to post
Share on other sites

Flex, that is a good idea to have the version displayed in the user program itself, I keep them in my rolling update excel sheet which has limitations

And it appears that you are running two instances of some versions?  For those that don't know, this is a very useful thing to have available.  Full details and other things that you can do with this capability are here:

cheers,  Aus

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...