Jump to content

Jazz Communication Problem

Recommended Posts

Hi Everyone,

I have a Jazz JZ10-11-R16 / MJ20-PRG which doesn't communicate

Error Message: "Communications could not be established..."

I've tried U90 ladder and also Unidownloader with the same results

I've put it into BootStrap mode, with the same results

I've used another MJ20-PRG and cable

I've tested the same PC/USB adapter/Port with Visilogic and a V130, working fine.

Version Used:


V1.10 (B03) HW: A Bin Lib: FE

BootStrap V1.10 (B00)

U90 Ladder V6.1.7 (DB 109)

Unidownloader V 4.1.01

I'll appreciate your suggestions.



Link to comment
Share on other sites

  • MVP 2014

Also, does the MJ20-PRG plug fully into the unit? Take the back off the PLC to check. We have seen the occasional case where the alignment of the connectors is slightly off and the MJ20-PRG doesn't plug fully in. Alternatively, with some misalginment the pins on the PLC connector can get pushed back and bent, then they do not plug into the adaptor even if it is pushed all the way into the housing.

Link to comment
Share on other sites

  • External Moderators

Hi Joe, Not all Serial to USB converters work with Jazz. You will need the Converter specified by Unitronics. With Vision PLCs and even with M90/91, any type of Serial to USB will suffice. Ron

It's true, not all usb-serial work with Jazz but they work with others Unitronics OPLCs. I have some customers had to buy the recomended Unitronics' converter.

Link to comment
Share on other sites

  • 10 months later...


I have the same problem as Joe.

The only differene is that I do not use USB adapter, I have COM port on my laptop.

I can connect with V130 but not with Jazz.

I use MJ20-PRG with 6 wire cable and MJ10-22-CS10 plug (also checked on MJ10-220CS10 - not working either).

Laptop is working on power adapter (not on battery).

I have tried dismounting PRG adapter, changing cable and changing plug - all seems to be ok. Moreover, the same set works on my friends computer.

I have also tried to reinstall U90 Ladder and deinstalling COM port and installing it again -> still nothing.

Any ideas what can be the problem? Because I am out for now and am not looking forward to the idea of reinstalling whole Windows.



Link to comment
Share on other sites

What version of Windows you are using?

If you are using Windows Vista or 7, disable the UAC.

See instructions here:


In U90 Ladder, go to Contoller > M90 OPLC Settings, click on Advanced, set the Parity to Even, the Stop Bits to 1, and the Data Bits to 7.

check the box of Force PLC settings to

Link to comment
Share on other sites

System: Windows XP

Settings: Tried everything - really. Forcing PLC, setting default values to U90 and PLC, changing U90 and PLC to other setting (eg.: 8/N/1, 9600, 19200, etc.)

And nothing - I think I will reinstall WIndows today and let You know if it helped...

Link to comment
Share on other sites

  • 4 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...