Jump to content

Remote Operator And Access


Recommended Posts

Good morning, please i have a challenge on the 2 issues listed below;

1.     I configured my unistream plc to ethernet and i was able to control it from a system to VNC but this is only when am around the facility using same IP with PLC but trying to access it from another region through another internet provider, it does not connect. please what is the way out so that i will be able to monitor and control remotely

2.     I tried configuring the android remote operator but its just giving configuration error. what is the way out ?


Please i need a way out to make my process completed.


Link to comment
Share on other sites

  • MVP 2023

I could be wrong, but my understanding is that Remote Operator and Remote Access are for the Vision line only. The UniStream uses VNC.

It sounds like you are trying to access the PLC while external to the network it's on. You must take certain actions in order to do that and I recommend that you consult with the IT professional that has responsibility for the intranet the PLC is on. This issue is unrelated to the PLC, but is common to every device that you might want to communicate with from the internet. One common method for accessing a PLC on an internal network from the internet is to use port forwarding on a router, though that is not the most secure way.

Link to comment
Share on other sites

  • 6 months later...

Hi -  Not trying to dredge up an old topic but this was a relevant thread I found in my search for a solution to this issue.  

I'm working with Samba PLC's.  I have successfully set up the Remote Operator and can successfully interface with the PLC when on the same LAN, but when off network I'm not able to get in.  

I had my IT contractor set up port forwarding and  have tried accessing using the new external IP address provided but thus far no comms when off network,  IE through  my cell phone's data connection.   

Are there other port settings that need to modified or where else should I be looking?  


Link to comment
Share on other sites

  • MVP 2023

Did the IT contractor forward port 20256 to the correct IP address of the PLC? Is there any firewall in place that might prevent access? Is the Default Gateway set correctly in the PLC? Are you certain about the external IP address (can you ping it from your phone)? Are you sure your phone is trying to connect through cellular and not through wifi?

I have done this many times and usually have no issue as long as the addressing is correct.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

This site uses cookies. By clicking I accept, you agree to their use.