Jump to content

Recommended Posts

After updating os I ve got te screen as in the attacment. I can comunicate with V130, and download the application but can t run it. I ve tried to reload OS again with uudated visilogic and again with no success. I am building aplication for local waterworks. Please help!

Regards,

Z.Matic B.Sc EE

 

v130problem.jpg

Link to post
Share on other sites

If your program previously worked, you likely have version conflicts. 

Reload the O/S you originally had in the PLC.  Power reset.  Load an empty program.  Initialise and Reset.  Power reset and reload your program.

cheers, Aus

Link to post
Share on other sites

Depending on how old the OS was, there may have been a change in how a function works. 

Try this, too, to see if there's some code causing the problem.

In Visilogic, go to Edit->Find Sub by Ladder Error Code-

image.png.3aa7dce08cfe6b8be79f93ac552900fb.png

 

Enter "7E" (your ladder error) in the popup box.

 

Joe T.

  • Like 2
Link to post
Share on other sites

Hi, 

Thank you gentlemen for trying help me,

Some more symptomes:

I ve updated Visilogic to a newist verision, then updated OS and downloaded to PLC. And with no success.

When I  tried to "Find Sub by Ladder Error Code" visilogic presented a comon subrutine wich is used to count pulses (flowmeter totalizer).

I don t know if something about subrutine is incomatible with new os or enything else but it is working on few other older aplications and it was just copied to this one. As the maater affact The whole application is built  based on the older one. 

here is the sub 

image.png.8ce07bdc4286f5476ba31feed3b8d519.png

Link to post
Share on other sites

That's good, Zoran.

This is possibly an example of why Unitronics has Version Swapper.  If you have an application that works fine on a particular O/S then there is no reason to upgrade it to a later version.   Many times on the forum you will hear "If it isn't broken, don't fix it". 

The temptation is great to always update and run the very latest version of Visilogic, but it can often create issues.   Many times "easy implementation" translates to "go backwards a bit to the older version that works".

cheers, Aus

  • Like 1
Link to post
Share on other sites
10 hours ago, Ausman said:

That's good, Zoran.

This is possibly an example of why Unitronics has Version Swapper.  If you have an application that works fine on a particular O/S then there is no reason to upgrade it to a later version.   Many times on the forum you will hear "If it isn't broken, don't fix it". 

The temptation is great to always update and run the very latest version of Visilogic, but it can often create issues.   Many times "easy implementation" translates to "go backwards a bit to the older version that works".

cheers, Aus

We say,"Don t push a nail into healthy foot".  :)

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Stuck again ! 

Each time TCP Raw Scan FB is activated os error screen Ive posted before apears.

Does anyone know if this FB has some problems?

Or how to controll it. 

Ive used tcp raw exemple from help to build the communication between  2 V130 s.

It is quite simple, but complicated to me because I am lack of communication knowledge. I just need to constanly read 2 MIs (4 bytes) from one PLC and store to another using TCP raw protocol (or another one if you gentlemen suggests so)

(procedure 7E means nothing - it is ran before scan FB is activated)

 

Please help.  

Link to post
Share on other sites

At first I ment to do the MODBUS TCP but It seemed to me that tcp raw was easier. But obviously I ll have to try it.

But before I try, I need some answers.

My V130s are curently on my desktop and are connected into same local network. But once the applications are comleted, they should be installed into two different lans. Communication must be performed through lan routhers. What should be defined in master modbus config. for slave - (IP and port number). Also what ports routhers should  forward.

Link to post
Share on other sites
18 hours ago, ZoranM said:

they should be installed into two different lans.

Once finally installed, what is the physical distance between the 2? 

It sounds like it might be kms, but if it is only 10s of metres, it would be much easier to use Unican.  You would have the need to buy 2 cards and cable, but then it doesn't need any other mucking around to get great comms.  As well, once it is done, you can remove one of the ethernet cards as you can use the plc with the card to communicate to the other via the UniCan link. 

Even up to 100m might be an easier and simpler thing long term.

cheers, Aus

 

Link to post
Share on other sites

The routers will forward an IP to another.  The first IP (on the same network as the V130) is the one that goes in the Modbus config block.

Also forward ports 20256 and 502.  

Are both PLCs set up as masters or only one?  If they're both masters, you'll need to allocate an additional socket and port in each - one for master and one for slave.  If this is the case I usually use port 503 for the master.

Joe T.

Link to post
Share on other sites

Communicstion is performed through internet. Each Lan has its own ruter with static IP adress. Also socket 0 sttings is alredy dedicated to simple Web server using port 80. Socket 1 settings have to be default to support remote operating and maintenance (port 20256). Remain sockets 2 and 3 have to be used. I don t need 2 masters. Only 1 is needed and it have to constantly write 2 MIs to slave. For future apps I ll need one more slave with same task but for now it is one. 

Backstory: water tank (master) reqests filling or filling pause from a well (slave) or two. Unfortunately trere is no fiber optics not any cable connescting tank and well, gprs or 3g is una wailable, so Adsl over publc telephone net is installed. 

Link to post
Share on other sites

I know, there are many solutions. Maybe I oversized a case. But the story is even more complex. My first duty is to menage electrical instalations meinteinace in the waterworks of whole city and 10 vilages around it. Due to lack of plc programmers, I have to build and mentein by myself. Each facility of 54 should be equiped with Ip video survailance in the near future. So the propper internet link is installed to support remote survailance and it can be used to monitor proces too. I achived to bild 11 systems with Just 4 components installed in Each system- V130 with ethernet card, EX-A2X and AI4AO2 so far.  I AM not going to install New equipmemt if I don t have to. 

Cheers

Link to post
Share on other sites

I ve performed modbus tcp successfuly!  I should do it at first lol. 

Still I dont know why raw scan block failed but let it not work :)

Now I am going to do some improvements. I need master to auto reconnect after conection is broken.  Example shows the socket connection line with necessery conditions but it is limited to connect only once. Can I remove the connect request contact at the begining and the reset coil at the end. I tried  setting SB 168 to 1. I thought it would automaticaly reconnect if I for exampele  disconnect the ethernet cable and again connect it but it did not.

Any suggestions how to reconnect . It is not sutable to manualy reset V130 each time connection is broken. 

Regards,

Z

  

Link to post
Share on other sites

Before doing anything else, have you done an Initialise and Reset?  Connection/Communication & OS/2nd Tab/bottom right.

On any change that doesn't seem to work the way I think it should, I do this.  It sometimes  cures issues, and is likely good practice to do it on any change. 

But a note of caution if it is done to a "finished" system on site.  Sometimes it might upset a process too much, so it may need to be delayed until it is OK.  Particularly if your project uses large averaging in readings and hasn't got an inbuilt delay to accommodate this, or if it adjusts startup defaults through running.

cheers, Aus

Link to post
Share on other sites

Alex is right. Pavel, look in the help files. I was partly familiar with keep alive ( Look my previous posts, a few years ago I learnt it with a help of forum) and I Just listed nearby SIs. When I found what I had been looking for,  looked into help files to confirm my thoughts. 

Pavel, I come from Smederevo, Serbia. 

😀

Cheers

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...