Jump to content

Recommended Posts

Hi,

in my current project I have a button on my touchscreen. If this button is pressed, MB33 is set and afterwards MB 10 should be set too.
But, as you can see in the image below, the execution of the net stops before MB10.

Basicly I copied this structure out of this tutorial : https://www.youtube.com/watch?v=8RyFPPE3Hdk&feature=youtu.be&t=572

In the tutorial they use the same sequence of contact and coil to turn a "LED" on the touchscreen on and off.

Any ideas, why it doesnt work for me?

grafik.png.dc127eddfec4589f0dacfe649bfa5cb5.png

Link to post
Share on other sites

Search your project for MB 10. If there is an MB 10 coil elsewhere it could be overriding.

The other likely possibility is that this ladder net is in a subroutine that is not being called by the Main Routine.

  • Like 1
Link to post
Share on other sites

Ah, okay. The ladder is in a subroutine. I thought the buttonclick would call it. So i have to call it in the main routine and the button click is just a condition for the further execution of the net? An why turns MB33 red when its not called?

 

Link to post
Share on other sites
50 minutes ago, CobryWZL said:

An why turns MB33 red when its not called?

That is just something VisiLogic does when it's online with the PLC. It's not actually following the logic of your program - it is only checking the value of each operand and displaying it on the screen.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...