Jump to content

Recommended Posts

I am using a V350-35-R2 with a EX-D16A3-TO16 and a IO-ATC8 to run PID control on a simple heater. i am have a problem getting the PWM on the EX-D16A3-TO16 to work correctly . the issue appears to be with the operand of frequency.  I'm not sure what I am doing wrong. i have attached a copy of the program. any help would be greatly appreciated.

heater.vlp

Link to post
Share on other sites

Hi, you must use power on operand for frequency MI1=PWM freq . Now it is 0 and output is ON for all the time.

PWM freq for this module is different for different type of connection

npn_pnp.thumb.jpg.303902b2e6590f6fa54839ce55900e32.jpg

PNP = 1-500Hz

NPN =1-32000Hz

You must use proper value for IO module hardware PWM Frequency power up value preset.

If you process is slow - you do not need to run harware PWM.

You can run slow software PWM SCAN ladder FB and use simple output for control SSR for heater.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...