Jump to content

Recommended Posts

Hello Everybody,

I face some issue with a V430 PLC and the last version of Visilogic (V9.8.90).

I used a project with the precedent version (V9.8.64) with no problem. I communicate with a motor, and it works fine.

I updated my computer with the last version (V9.8.90). It required to update the firmware of the PLC (as usual with new version). Update is done corectly. But now when I use a SDO Download, my motor makes the first movement, but I have SB243 switching on. Error code is a Timeout (SI225 = 10).

I tried with a second PLC, and exactly the same issue : timeout on motor communication when sending SDO.

Any Idea?

PLC ID = 1, Mode "CANopen & Servo" (was CANopen before), 500 Kb, Timeout 0.5 sec.

ID for motor : 2

 

Thanks for your help !

Nicolas

Link to post
Share on other sites

Unfortunately I don't have an answer to your question, but I post to remind everyone that unless there is a necessary & known reason to do so, do NOT routinely update the software and firmware on a working PLC. There is usually never a reason to do this, even when making an update to the software. Use the version of VisiLogic that the program was originally written in to perform any updates. Unitronics makes this fairly easy with Version Swapper.

Even when creating a new program, if there are other PLCs in service, I will continue to use the version that is on the other PLCs to keep things consistent.

Link to post
Share on other sites

Hello Flex727 and Kratmel,

Thanks a lot for your responses 🙂 A bit desapointed by the one of Ausman pined on the top of the forum 😕. I understand this point of view of not updating the software "just because we can". But the version 9.8.90 has interresting function while allowing URB Remote I/O. I didn't took the risk to update just for fun 😉

Anyway. I contacted my French reseller too, and made few more tests. It seems the bug is in the OS of the PLC. Until not upgraded, it works fine. Once updated, even with the same program it doesn't work anymore. When using your solution Kratmel, ID1 is OK, but red for ID2, 3 and 4.

Then I face a dilemna :

- if I need CAN, I cannot use the last version, then I cannot install URB Remote I/O. I will continue with the old I/O (but it takes too much place for my project)!

- if I need URB Remote, then I must forget CAN and go back to RS485. Bof bof (in french in the text 😉 ).

From now, I will keep version 9.8.64, and forget the new functions. Just have to recopy the programs written on 9.8.90 before seeing it is not working.

Hope it will be solved soon 🙂

With best regards,

Nicolas

Link to post
Share on other sites

Report the issue to Unitronics and they will likely have it taken care of quickly.

Also, go ahead and use 9.8.65 instead of 9.8.64. The .64 version had a few minor issues IIRC. Your PLC won't know the difference between .64 & .65.

Link to post
Share on other sites

This is from new  Visilogic CANopren+ Servo help

CAN_compatible.jpg.a266f91f7b43c696013013312db2fc36.jpg

But it is about older version of Visilogic

It is present in 9.8.65 help also.

Maybe something no documented changes appear in new visilogic. But it is not present in help  :(

 

Please try to check  code in

SDW34 ----CANopen: Abort Code in SDO Abort. Check Help file for codes

SDW36 ----CANopen: Bus OFF error. Check Help file for codes

  • Like 1
Link to post
Share on other sites

Hello guys,

Thanks for your help! I checked SI and SDW, but nothing looks anormal. The SDO status is located in SI225 looks correct (reports a timeout error), then it seems I have no incoherence between the old and new values you given to me with the picture, Kratmel.

I had a look to SDW34 and 36, and both are equal to "0", then no more information there.

I reinstalled V9.8.64, and it works fine. I will switch to 9.8.65 as you suggest Flex727, and wait for a new version 😉

Have a nice week !

Nicolas

 

 

Link to post
Share on other sites
On 5/20/2020 at 1:39 AM, Nicolas BGI said:

A bit desapointed by the one of Ausman pined on the top of the forum 😕

By all means update if you think a new feature is going to make your project work much better.  But be prepared for the possibility that everything that currently works OK may not continue to do so.

During all of the updating process, did you do an Initialise and Reset?  In theory with everything you've done, such a thing is not needed, but it often does cure strange issues and is worth trying before giving up. 

Finally, please tell me that "Just have to recopy the programs written on 9.8.90" doesn't mean you saved over the top of the old projects and don't have them individually saved!!  😢

cheers, Aus

Link to post
Share on other sites

Version 9.8.90 introduced re-directing the CANbus port for servo control.  If you do servo, you can't do UniCAN.  Something may have gotten janked up on CANOpen in this version.

The best course here is to contact Official Unitronics Support directly with this issue by sending and email to support@unitronics.com.  The forum is not the official support channel, although Unitronics employees do weigh in from time to time.

They can also roll your program version backwards if needed.

Joe T. 

Link to post
Share on other sites

Hello guys,

Thanks again for the support! My dealer sent the programs to Unitronics, so they will check it 🙂

@Ausman : what do you mean by "Initialize and Reset"? After update, I switched PLC Off an On several time, so it should be OK. Or it means something else?

No, of course I kept the old version. But I added some function on my program Offline with the version 9.8.90. So just have to add those new functions to the orignal one (V9.8.65) without converting to V9.8.90😉

@Flex727 and Joe : OK, thanks for the tips 🙂

Nicolas

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...