Jump to content

Recommended Posts

If you are installing the Suite, you will likely encounter the need for Net 3.5 to be installed.

For ages on various computers' new installs I've been banging my head on it not working properly.  I'd end up with a message box saying it failed because "the service cannot be started, either because it is disabled or because it has no enabled devices associated with it".

Following a quick chat with Saragani, I pondered him saying the same thing I've found all over the place....that the normal method of turning it on in W10 is to enable it via Windows Features.   (If you don't know, the shortcut to get there quickly is to run "optionalfeatures".)

I always tried this and it still didn't work.  I had also downloaded and tried the offline installer without luck, many times. 

Finally the light bulb turned on.  In all my attempts I was doing it on systems that I had disabled updates.  Once I re-enabled them the process went fine.

One would think that a fully offline installer would work ok without needing to "ET Phone Home" but it is not true in this case.  I think it is the only offline installer I've had that exhibits this behaviour!

And before you ask/dictate/suggest that I leave updates on all the time, in most situations I routinely let the significant updates come through by keeping up to date with current advice.  I've had even minor updates wreck things that were working fine, hence me clamping down on the process which can waste large amounts of data on systems where it matters.  As well, I really really really don't like the next update reinstalling all the useless crap as well, like Xbox etc.   There are ways around this too, but how far does one have to go to keep your system the way YOU want it, rather than the way SOMEONE ELSE wants it!

bash-head.gif

cheers, Aus

 

Link to post
Share on other sites

I went through the problem of updating not only in the computer.
You can't even talk about a smartphone at all - it lives its own personal life ...
The printer did not want to print because the memory defragmentation requires an update.
Now you should probably expect updates for the microwave, vacuum cleaner and electric kettle.

P.S. Therefore, from time to time I make a full copy of the contents of the computer - with a note - everything installed worked ...

But it did not help:
I open visilogic projects 9.8.65 from a second system running from another hard drive with the latest version without saving them.
Accordingly after that, it is impossible to run old 9.8.65 project  from the old hard drive via 9.8.65 installed on it. The new version from another hard  did something with 9.8.65 on the old disk.

I must reinstall visilogic  on old drive (full copy not help - new project lost) .

Link to post
Share on other sites

I know we are digressing, but for me, most of the time a project made on a newer Visilogic version will try to open but display an error.  Most of the time, but not always, you then have to close Visi in Task Manager.  Open the project again and it will bring up "Visi not shut down properly, reload blah blah" and if you select ok it will open the newer version, which you can then work with. 

I do this frequently on the forum's user projects as I am still sticking with just 8.65 and many of the submitted projects are done in later versions.

cheers, Aus

Link to post
Share on other sites
7 hours ago, Ausman said:

I do this frequently on the forum's user projects as I am still sticking with just 8.65 and many of the submitted projects are done in later versions.

Yes Ausman, i do the same thing... but in this case visilogic stop to open his own "normal" project...

And after try to recovering with "OK" button - Visilogic crashed. Only reinstall help to solve this issue.

Link to post
Share on other sites
16 hours ago, Ausman said:

I do this frequently on the forum's user projects as I am still sticking with just 8.65 and many of the submitted projects are done in later versions.

I sure wish Unitronics Support would reveal their super secret way of rolling back the version on a VisiLogic project.

Link to post
Share on other sites

Warning, not advising this at all.......:)

Doing the above method lets me then save under the current version. The hidden issue is that perhaps something that is utilised in the project then doesn't show up if it is only in the later version.    However....

Flex, you could always use your many installs of Version Swapper to look at what changes.  Do some saves of the same file under different editions and then peek using the likes of Notepad+.

Something obvious and tiny might show up.  Or it might be a totally different way of assembling the file which will completely klang the idea!  

I can't do this as I shifted away from Swapper and only run one version these days.

cheers, Aus

Link to post
Share on other sites
19 hours ago, Ausman said:

Flex, you could always use your many installs of Version Swapper to look at what changes.  Do some saves of the same file under different editions and then peek using the likes of Notepad+.

Something obvious and tiny might show up.  Or it might be a totally different way of assembling the file which will completely klang the idea! 

Great suggestion. When I have some time I'll try it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...