Jump to content

Recommended Posts

Hey All,

Got a problem that popped up yesterday that I can't seem to wrap my head around.
Maybe someone else has seen this before...

I have a freezer that is controlled with a V280, three Type T thermocouples into an IO-ATC8.
(module four in a bank of five)

At the points being monitored by the T/Cs I typically have readings between -200 & 40 deg.
Yesterday, all three suddenly went whack, reading a couple hundred degrees higher that actual temp.

This morning I tried;
swapping out the IO-ATC8 module (thinking it went goofy), no change
reset/init of the PLC (to clear out any whacky numbers), no change
reloading the program into the plc (in case the module config somehow changed), no change
wiggle-jiggled the expansion connectors between modules, no change

Next stop, swap out the PLC, but I can't do that today as the freezer is in use.

There was an event yesterday morning, where one of my techs said the panels 24V supply
got shorted (stray whiskers on a terminal block), but the PS came back after he cleared the fault.
And it is giving me 24volts....

Thoughts or suggestions anyone??

JohnR

 

image.png.cba49526a856fd45cdcb04c733067cd1.png

Link to post
Share on other sites

In my limited experience I have had similar issues.  
 

things to check/try. 
Even though your power supply is 24 VDC it may not be large enough.  Try a higher watt supply and a quality one.  

Check how close your thermocouple wire is to motor leads.  

Grounds, grounds, grounds.  We earth ground every tank, isolated pipe, panels, etc.  if it’s metal... earth it.  

good luck 

Link to post
Share on other sites

Hi,

As this problem happens after PS shortcut, you have to check power supply.

1. Check PC for output voltage, voltage fluctuation and ripple.

2. Check PC for load. Recommended to keep PS loaded not more than 80% of maximum load.

*If maximum load is 2.0A, then use PC rated for 2.5A.

3. Replace PS for new/good working one.

Best regards,

 

Link to post
Share on other sites

Power supply didn't help....

Back to square one and replaced the ATC8 module again with another used spare, and I'm back in business.

Two used modules in the trash, and one new module on order.    🤬

Thanks all for the suggestions....

Link to post
Share on other sites
2 hours ago, John_R said:

Two used modules in the trash

This, in my opinion, has some logical explanation.
There is something that the module does not like in your installation.
And this is likely to happen again.
Having faulty modules in hands - I would try to understand the reason analyzing the internal scheme.
Therefore, if such a module worked for a long time and broke - you also need to change the sensors that are connected to it.
It is not too expensive but it is usually a cause of breakage.

If the module is installed in a new installation and fails - usually an error in installation, connection, power supply and grounding.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...