Jump to content

Recommended Posts

Hi everyone!

I'm trying to comunicate my PLC with a Energy Analyzer by the protocol MODBUS RS485 to read some registers.

I configured the program with this parameters:

PORT 1 (COM1)

image.thumb.png.cc70abbe08c9f1c655dc5e10a02e223b.png

I configured the energy analyzer with the same parameters.

To read the registers :

image.thumb.png.5e2e57dc2c7a4e4ba7e4fdb2747893b6.png

 

I'm using the V700, and change the DIP Swtich to RS485.

Even after that all, isn't comunicating. 

Is importante to say that the energy analyzer is comunicating with PCs, so I don't think that the problems is with him.

Can you help me understand what may be happening?

Thank you all :)

 

Link to post
Share on other sites

Hi, try this checklist:

- wire swap A & B;

- check - is it V700 and Energy Analyzer correct  in master-slave mode;

- configure com port and disable all modbus send net. Connect V700 A&B wires to PC - Energy Analyzer RS485net.  Go to info mode and try monitor RS485 packets via V700 com port.

 If you see something correct than port and speed connection is OK.

- try to activate Modbus and check via Info mode - what is go from V700 and from Energy Analyzer;

- try to use single Modbus command activated by button and  check Modbus status.

 

As i see you try to read MF 44 direct via modbus.

On forum is present topics with Energy Meters float read via Modbus issue - maybe in your case some tips and tricks with two MI to MF convertion  needed.

Please post Energy Analyzer model.

 

  • Like 1
Link to post
Share on other sites

Further to Kratmel's good advice, it is worth saying that many modbus things will not communicate to Visions at greater than 9600.  It is always worth starting slowly and trying bigger baud rates after getting things working ok in the first place.

I also note you have 2 stop bits.  ??    I'd also make your timeout bigger, along the lines of the previous baud rate comment but in this case it is start big and reduce.

Why, and how, are you working MB107?

cheers, Aus

  • Like 1
Link to post
Share on other sites
On 10/23/2020 at 5:53 PM, Ausman said:

Further to Kratmel's good advice, it is worth saying that many modbus things will not communicate to Visions at greater than 9600.  It is always worth starting slowly and trying bigger baud rates after getting things working ok in the first place.

I also note you have 2 stop bits.  ??    I'd also make your timeout bigger, along the lines of the previous baud rate comment but in this case it is start big and reduce.

Why, and how, are you working MB107?

cheers, Aus

Your are right.

I have changed to 9600 and the comunication worked, but then when I downloaded the program with the new paramaters the on-line connection via serial and TCP/IP,  now its not working and I think that it is because the baud rate. I test in another PLC that was with the same program but with other baud rate (a greater one) and the on-line connection worked.

Now I can't conect with the PLC to change that... You have any ideia what can I do now? I have already try to connect with a cable to serial connection and reset the PLC but that isn't working.

image.png.f2f20f70cd7f67d03131cab0a621e3b2.png

The MB 107 is for simulate the SB2, just for test.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...