Jump to content

Configure analog inputs


Recommended Posts

I have a V700 with an EX-D16A3R08 expansion module.

When I initially set this up, I selected the PLC, the expansion module, and that was it.

I assigned inputs and outputs in the VisiLogic software and the digital inputs and relay outputs work as expected.

However, when I got around to using the Analog inputs, I was getting no value. I realized I didn't configure them in the Hardware configuration and went to that tab.

When I click on the EX module, I can see the 3 analog inputs, but when I click on the 4-20 drop down, it basically freezes. It doesn't allow me to select filters, add a description, nothing. I can't even hit okay and have it remember the 4-20 option. The only way out of this is to cancel...

I have this same issue on 2 separate PLC's, so I hope this is operator error and set-up related, but I have watched over 10 anaolg videos and searched the forum and can't find what I am doing wrong. I assume it is something simple, but I am clueless. 
 

Thank you

Link to comment
Share on other sites

  • MVP 2023

As Kratmel says, was/is Admin used?  By this, "Install as Admin" does NOT mean simply installing it when logged as you being a user with Admin rights.  It is specifically Right Click on the installation file, and choose Run as Administrator.  This is a very confusing difference and often causes issues with people thinking they have installed it correctly.  After this special installation procedure and a reboot, you then need to locate the Visilogic.exe file which is normally in C:\Program Files (x86)\Unitronics\Unitronics VisiLogic_C\Main, and set it to Run as Admin in Compatibility which is second tab under Right Click/Properties.  Reboot.

If  you didn't use RightClick, save your files and then do an uninstall using Revo portable to get rid of everything, reboot and start again doing the above.

If you did do RightClick, then the next ask by Kratmel is relevant.....what Windoze version are you on?

cheers, Aus

Link to comment
Share on other sites

Thanks for the quick response Kratmel,

I finally figured it out. I have been doing most of this work at my desktop, but the debugging was machine side. Of course, the pop-up window for configuring the analog was showing up somewhere off of my laptop screen🤬

So after about 2 days of scratching my head, I went back to my desk and when I tried to configure the inputs, the pop-up was on my main screen

Link to comment
Share on other sites

  • MVP 2023

OK Wet, that's great.  You might want to have a look at No. 3 in the "14 pinned topics" at the head of the Vision forum.   Worth remembering, or at least noting the existence and location of(!) all the tricks mentioned.

https://forum.unitronics.com/topic/6229-ongoing-14-topics-almost-worth-pinning/?do=findComment&comment=25196

cheers, Aus

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...