Jump to content

Problems reading voltage level on analog inputs A0 and A1


Recommended Posts

  • 3 weeks later...
On 18/2/2021 at 17:06, Flex727 said:

Podría ser útil si mencionara qué hardware estaba usando y cómo lo configuró en el software y cómo lo conectó.

I am using a unictronics PLC v130 tr6. I could not find the form to read the pressure sensor that gives readings in voltage

ego1.PNG.15573ffcba8bf21297f5d82db68b0c70.PNG

ego2.PNG

ego3.PNG

Link to comment
Share on other sites

Moved to the correct forum.

Your V130 has 10-bit analog inputs. That means the 0-10V input will be read as an integer from 0-1023 and placed in the register you assign in the Hardware Configuration (you have MI 26 and MI 3 for analog inputs 0 & 1, respectively). You can convert that from 0-1023 to 0-10V by using the Linearization function in ladder.

Also, be sure your jumpers are set correctly for the inputs. An Installation Guide should have come with your PLC, but you can also find it in PDF form on the Unitronics website.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...