Jump to content

Need help setting up stepper motor pls ๐Ÿ™


Recommended Posts

Hello Everyone ๐Ÿ™‚,

I'm trying to set up a stepper motor to run with a V350-35-T2, and I'm pretty sure I'm not setting it up correctly. Could someone guide me a bit? I'm using a DM542E drive (PNP, currently set to 1200 rpm), which is driving a SST59D5255. I have the PLC and drive wired, and HSO setup, as indicated in the attached diagram.

When MB0 (Run MB) goes active, there is a 0.3V drop on O0, and DW0 (Current Position) increments until it reaches DW1 (Target), at which point it cycles back to zero. There is no observable change anywhere else, and no changes to the voltages from the drive to the motor.

As I mentioned, I'm highly suspecting my wiring is not correct. I was unable to find a guide for this in the setup documentation, programming guide, or online forums. Could someone point me in the right direction please? Thanks in advance!

46336511_HSOsetup.thumb.png.b4237dea708ec65d2beebeec8e7e1eb4.png

Link to comment
Share on other sites

You've got the polarity on the outputs wired as sinkers, not sourcers.ย  The T2 outputs are PNP type.ย  Your wiring would work if you had a -TR20, where the outputs are NPN type.ย  Don't forget to connect power on the output connector as well.

image.png.8a34ca6553fc8710646ac6470ec595cc.png

ย 

Hook it up like this for a -T2:

image.png.e6e55bf267d6e0597dffbd0af1d9b2dd.png

ย 

If you've got 2K resistors that's fine - all you're trying to do is limit the current through the optocoupler.ย  We use 2.2K resistors.ย  If you want to go all OCD and calculate the current through the optocouplers go right ahead.

You may not be happy with this setup, as the max frequency in the spec sheet on the -T2 is 500 Hz.ย  I have put a scope on this and the waveform gets triangle shaped the faster you go and becomes unusable at about 1200 Hz.ย  Your results may vary.ย  The -TR20 boardย using the dedicated HSO NPN outputs is MUCH faster, with a maximum speed of 200 kHz.ย  I've been down this road and the PNP outputs are horribly slow for a stepper.

There are other models that have the NPN HSO outputs as well.ย  Just not the -T2.

Joe T.

  • Like 1
Link to comment
Share on other sites

Thanks @Joe Tauser, that was a big help! I essentially had it wired backwards ๐Ÿ˜…, but now I got the motor spinning, and changing directions and speed as desired. I was not aware of the freq limit, but I think I'll be ok. I messed around a bit with different speeds and the range I can get will suit my needs. Thanks again!

(best answer! ๐Ÿ‘)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

ร—
ร—
  • Create New...