Jump to content

UniOPCThreadNode and processor load

Dark Neptun

Recommended Posts


I have problem with thread UniOPCThread, which takes about 40-80 % power of 3-core Athlon II processor under Windows 7 Professional

After OPC server starts everything is ok, but after start of visualization software (Control WEB or Reliance)

with about 900 tags (400 MB, 400 MI and 100 ML) threand UniOPC takes this part of processor operation power.

I tried it also on the other computer with Intel i3 (4-core) and problem was the same, just it was about 30-50 %.

There is no write cycles in scripts, just if there is write on screen in visualization, there is write over OPC to PLC.

After I close Reliance (vis. soft.) it is always a message of UniOPCThread - "Error 111 - Overflow" and I must "kill"

Reliance in processes manager.

I tried run UniOPC.exe and UniOPCThread in compatible mode Windows 7 and Windows XP SP3 mode, but result is the same.

No antivir was installed in those tests.

Do you have solution of this problem ? Thanx a lot !!

  • Upvote 1
Link to comment
Share on other sites

  • 7 years later...


Unfortunately, this high CPU problem is still present in UniOpcServer (2.0.14).

We use it to communicate with 4 PLCs (2x V1040 , V120 and V130),
and read 273 tags total, at 1 sec refresh rate.

As soon as the visualization software starts (Provicon VisionX9),
the CPU load goes to 100%, UniOpcNodeThread.exe uses 70-80%.

The PC which runs OPC server and the SCADA software has a i5-2400 CPU @3.1GHz.

The OS is Windows 10 64 bit 1903.

Is there a newer version of UniOpcServer available, or are there some settings to tweak?

Thanks in advance:




Link to comment
Share on other sites

Thank you Isakovic for your reply!

I know this problem is there long ago, because of this,
in the past years we have also switched to Modbus/TCP from OPC wherever we can.

Sadly in these particular case we can not modify the PLC's installed.

I hope some developer at Unitronics can make a fixed version of the UniOPC Server,
or at least explain, why it uses all of the CPU even if there are no or very few OPC transactions performed.

Link to comment
Share on other sites

  • 1 year later...

Hello everyone!

I think that I solve this problem.

I noticed, that this error of UniOPC displayed, because opc server (or oplc) does not have time to process the corresponding amount of data for the period of time specified in the settings of opc server (update rate time of port settings). When I try to increase this settings to several seconds this error is gone. tested 3 days


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...