Jump to content

Recommended Posts

Hello. Sorry for my english.

I have a problem with writing data to SD card. I've tried many options but i've exhausted ideas.

1) First - I'm creating data buffer using SD -> Create Delimited Line

issue 1) When I use Write Delimited Line, in file I see nulls (one line of CSV uses about 50 bytes and 462 bytes of null). Such behavior is unacceptable.

2) I call several times SD -> Create Delimited Line and adequately fill the memory (XI0.. XI256), so I had a 512B data.

issue 2) When i call Write Delimited Line, it returns me an error with number 256. SI66, 67 and 68 equals 0. (attachment 1)

3) I tried to get around and I thought that the last byte of data must be zero. XI255 and XI256 set to zero.

issue 3) Calling Write Delimited Line sometimes works, but usually returns 128th Error. SI66 == 0

4) Another attempt to work around. I'm generating buffer with Create Delimited Line, open file with SD Utility Open File (W), writing data with SD Utility Write Next Chunk (W) and after finish i call SD Utility Close File (W)

issue 4) Close File isn't working. SB327 is always one.

V350-35-R2 (B)

O/S: 3.3 (03)

BOOT: 2.2 (01)

BinLib: 0-2.1 (02)

Factory boot: 1.3 (01)

OS Version: V3.3 (B3)

Please help me.

post-805-030097300 1296587195_thumb.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...