Jump to content

UniLogic Festo CMMO modbus operation


Recommended Posts


I'm new to PLC operations, and I was hoping I could get some help getting started with MODBUS communications.

I have a PLC/HMI running UniLogic and Festo CMMO which I am trying to run over MODBUS TCP. I have added the remote slave, and downloaded the program onto the PLC. However, I haven't been able to get any proof of the connection. I have added registers (3 and 17) based on reads to tags (INT16), but they all display as 0. I have also tried displaying the value of slave.sessions, but it also shows 0 which leads me to believe it has not even tried to start the connection yet.

I feel like I'm missing some critical first step or debugging process?

I would appreciate any help or point in the right direction. I'm using the controller linked below and trying to follow the MODBUS instructions starting on pg 27.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...