Jump to content

Jazz Modbus communications

Recommended Posts


I have a Jazz OPLC which I want to use as a MODBUS master, to read from, and write to 3 inverters on an RS485 modbus network.

I have downloaded a U90 sample program from a thread on the foum, which has enabled MODBUS comms on the Jazz. It now reads a value from Node 2 on the network.

Now I cannot get U90 Ladder to re-connect to the Jazz. I know this is because you cannot have 2 comms paths into the Jazz, but how do I put code in there to re-enable RS232 comms?

What do I do?

Link to comment
Share on other sites

Please try first to stop the controller from Info mode > System.

Then - change the Modbus config command from 600 to 599. This will let you to communicate with U90Ladder even the port is configured as Modbus.

Of course - you have only one port. If you switch ot PCOM (Unitronics native protocol), then it will take about one minute to Jazz ot return to predefined Modbus settings.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...