Jump to content

Recommended Posts

Hello all,

I am having serious problems with the configuration of the advanced webserver.

I have continued the manual correctly (or I believe that)


and I do not manage to make it work. I thought that it might be a problem of ports in the router, but I it opened all; The bits SB217 and SB218 (SD Card Present and SD Card is write-Enable) is to "1".

I kept on doing tests and change ' Sock INIT ' to the protocol HTTP, TCP and UDP but with none it worked.

The strange thing is that when I do ping to the IP of the PLC in the port 80, he answers me unless it should be try to open the webserver.

Not which can be the error and I am a little lost, can they help me?

Thank you from already.

P.D. To forgive my English.

Link to comment
Share on other sites

Hello again,

I have kept on doing tests:

- I have updated the O/S of the V130 up to 3.6 (14).

- I have changed of router.

- I have changed the IP, so much that of the PLC, as that of my PC.

- I have tried with all the protocols.

And it continues without working: (

To help me please

Link to comment
Share on other sites


As I understand you are trying to run the Advanced Web Server.

In order to eliminate the router settings, try to connect your PC directly to the PLC.

You do not need to change the socket setttings (Configured as TCP_RAW), just change the IP address, Subnet Mask and default gateway to match your network.

Copy the files from the ZIP to the SD card in folder Web and download the application to the PLC.

Now try to type the IP address of the PLC in the browser address bar and check if you can view the page. (first make sure you can ping the PLC )

Link to comment
Share on other sites


Thanks for the response.

I do not understand:

In order to eliminate the router settings, try to connect your PC directly to the PLC.

By means of connection series? Crossed Ethernet?

Is it normal that with TCP_RAW loses the connection in the Visiologic?

Do I suppose that it will be ethernet crossed, if it is like that, where I can find the scheme of the cable that I need to mount it?

Thank you again and excuse my ignorance.

Link to comment
Share on other sites


I have managed to do it BUT only once! I explain myself:

I download the application the PLC, do to him ping his IP and he answers me, I enter the explorer introduce this IP and the page ' Start.htm ' appears, (so far well) but of to load and he does not answer already again ever.

I do him again ping and he does not answer, and the page does not load any more and expires.

Likewise I lose the communication with Visiologic.

I have read in the help, which the Socket 2 uses for SCADA systems which use MODBUS TCP over IP.

I wonder: would it be possible to use the Socket 2 for the Web Server in Modbus Tcp and to leave the Socket 1 for communication with Visiologic?

Thank you

Link to comment
Share on other sites


Did you make any changes to the application or did you download it as it is?

If you establish connection with the PLC via VisiLogic do you also lose ping after the connection is done?

Try to do the same test with a cable connected between the PLC and our PC. (It doesnt matter if it is cross or straight)

Beside of socket1 you have another 3 sockets which you can configure as you like.

For example socket 3 by default is TCP slave port 20257 so you can use it for communication with VisiLogic.

It is better to leave socket1 for the Web Server since the Web soubrutines logic is already linked to this socket.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...