Jump to content

Trouble with IO-PT4 and v230 with a PT100 RTD

Recommended Posts

I have a project I am working on that uses 3 RTD PT100 sensors to measure temperatures where I am heating water in 15 gallon tanks.


One is directly mounted in a 15 gallon tank where I have a 5000 watt 240V heating element that is bringing it up to temp.


One in inline with a circulation pump pumping heated water through it.

One is in another 15.5 gallon tank that is heated by burner.


All three configured in Visilogic as PT100 385 sensors.


Two of the three work fine.


The one in the tank with the heating element is funky. It acts funny. It ready wrong at low temps then somewhere between 40 and 50 dec C it starts to read correctly.


I can measure water when the sensor reads 30 C and the actual temp is around 80C 


this causes havoc with my PID as you could imagine. I changed the RTD and still same thing. I also changed to a different input and still same issue.


I can't seam to find where this is going wrong. The other two work fine even when I swap them with the one that does not work, so it seams to be in the program? or perhaps something else that I am missing?

Any help would be appreciated.




Link to comment
Share on other sites



Are you looking at the raw value for the PT100 sensor within the logic?


Which I/O module are you using for the sensor? I would check the hardware and verify that it is wired for PT100 sensors. Also, within the hardware configuration is the analog input set for PT100 (392) or PT100 (385)?


To clarify further clarify; as for the sensor, if you swap it to another analog channel does it still work improperly? If you use one of the PT100 sensors that is working correctly and place it into the channel that is not, does it still work? This will help to determine if it is the sensor, hardware, or software that could be the issue.

Link to comment
Share on other sites

It is on a IO-PT4 I tried several channels with same results.

Checked it is set for PT100 with 385 and also tried .392 as well same results. 


I am checking raw value as written to a Memory Integer by the IO-PT4


Last night I wrote a new program to test it that only display the current temp value on HMI, nothing else in the program and ran it. I then manually turned on the outputs to the heater and I had exact same results.


I then took one of the other RTD that worked from its tank and placed in in the liquid that I was heating and it worked. So I pulled the troubled probe and put this in its place but left the wiring alone. I didn't change wiring to see if it would still read ok like it did when I held it in the water.


It did not work. it did the same thing, holding the one I took out in the liquid now worked. So it appears to only happen when I have it mounted in the tank.


it is mounted using Camlock fittings so I can quick release it I also tried isolating its ground in case it was ground issue. I think it might be related to noise somehow generating from the heating element. That element is just above and perpendicular to the probe see attached photos. Perhaps the heating element is generating too much EMI? The placement of the Probe and its orientation to the element causing issues? or could it be mounting it in the stainless steel tank which is grounded via the element mount. causing some interference with the signal? since it reads fine if I hold the probe above with its probe in the water but above the element and not to the side

Complex little bugger of q question I am sure. Any help would b appreciated :)








Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...