Jump to content

MODBUS communication problems

Recommended Posts



I have a problem using MODBUS communication with JAZZ JZ20-R31.


I have two slave devices connected.


I just read from the first one, and i just write to the second one.


I had the first one alone before i added the second one and communication worked just fine.


Problems came when i added the second device (the second one is a PLC from another company and it's used to send written data to the web).


Yesterday communication worked for a few cycles, but after that it completely stopped, even with first device - there were no LED lights blinking like it should.


Today i restarted my main JAZZ and talked to the guy behind the second device. He says that he sees the RS485 communication and that i am writing data to his device three times in one second.

My MODBUS is setup with timeout set to 3000msec and 1 retry. I checked my write function, but it is only called once a minute (roughly)  as i intended at the beginning.


otherwise i have MODBUS commands separated by steps of 4 seconds each, so one command can't interfere with another.


I tried to increase step times, changing timeout and retry on MODBUS setup, sending data in multiple steps, but nothing seems to help.


What could be the problem here, i ran out of ideas...?


Thank you,


Best regards,





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...