Jump to content

Cannot communicate with M91-2-T1

Recommended Posts


We have a M91-2-T1 that we haven't used for a while, and have just got it out again recently. I am trying to communicate with the PLC via RS232, but cannot communicate with the PLC. I am using:

  • USB to serial cable (Prolific, driver version, connected to;
  • DB9-RJ11 cable which we made according to the pin assignments in the U90 software manual (we also have another one with the RxD/TxD reversed because we thought we had the two around the wrong way)

I also tried using an older computer which has a RS232 port, and no luck there either, so that ruled out the problem of the USB to serial cable.

I have checked the COM port and settings (reset everything back to default), and they all seem fine. Is there a way I can test if the connections are correct by say, use HyperTerminal to send commands to the PLC, or is there any way I can find out what the problem might be?

Many thanks,


Link to comment
Share on other sites

  • 4 months later...

Hi Danny,

I am sorry for missing your request for help.

Was the problem solved or you need further help?

* PLC can not answer to any HyperTerminal input as by default it use VisiLogic communication protocol.

** To check cable or adapter, you need to shortcut pins 2 and 3 at 9 pin RS-232 connector.

Entering any symbols from HyperTerminal will echo back.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...