Jump to content

RTC date and time are swinging between two values

Recommended Posts


My plc's RTC date and time are continuously swinging between two values, several times in the same second. RTC switches between today and a date from May 2018 (between 16th and 22th,  not always the same day, with a different time).


CPU OS 1.36.44

UniLogic 1.36.63

I've tried to set date and time from UniApps, from UniLog with "Set RTC", to check "auto-sync", but nothing change. I've also tried to download an empty new project to plc, just with some watches on RTC Date: same issue.

It's a problem as I want to use a schedule but it switches continuously between true and false...

Does someone know what to check else? Or what to do?

Thanks in advance.

Link to comment
Share on other sites

"Download All" empty project -> download successfull, but no changes about RTC

Note: RTC Date is unstable but UTC Date is stable and correct.

Forced remote update firmware, then "Download All" again same empty project -> the download was successfull, I think, but then I lost the connection to PLC "Please check IP configuration". If I try "PC - PLC Communication", I get "Ping to device wasn't successfull"

I tried to restore IP configuration with an USB action file, but the actions permissions has been removed from PLC (while they are still activated in the empty project)

30.04.24 11:51:21 Command Write Panel IP was not defined in UniLogic
30.04.24 11:51:21 Command Write CPU IP was not defined in UniLogic

I can't access my PLC anymore...

Link to comment
Share on other sites

First - attempt to use USB cable and ping than connect VNC to IP

You can check if this network exists after connecting USB cable to powered-on PLC:


Windows IP Configuration

Ethernet adapter Ethernet 8:

   Connection-specific DNS Suffix  . :
   Autoconfiguration IPv4 Address. . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

Link to comment
Share on other sites

Thanks for your help. I will try with USB cable on thursday.

Note: The RUN led was orange blinking on PLC (Stop mode according to help).

I've tried to shut off / restart it: RUN led became orange on, then after some time, orange blinking.

Link to comment
Share on other sites


I've connected the PLC with USB cable and got access to it.

This message box has appeared and I've followed its instructions:


Now I have empty project on PLC and the RTC date is still unstable.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...