Jump to content

Recommended Posts

Hi All.

Currently using the latest version of Visiologics software with a v1210. After working with it for some time I powered the unit up and it appears to have lost all of its OS files, bin, boot, os etc. Trying to load the files back in and it gets 1/2 way through the download process and then fails every time. No explanation just a red X. I've tried downloading both automatically and one file at a time. I've uninstalled and then reinstalled the software, which has had no affect. Any other thoughts? I do not like having a very expensive brick on my desk.

Thank you in advance.


Link to comment
Share on other sites

  • 1 month later...

Hi R.Mozes,

I had this same problem and discovered a couple other things.

First using version 9.4.0 without any other version prior on your computer, for some reason it will never install the new keypads.

I had to uninstall version 9.40 and go back to version 9.3.0 then I had to update OS.

Then after that was complete and I had the old keypads showing, I uninstalled 9.3.0 and then installed 9.4.0 and once again I updated the OS and this time the new keypads worked after doing a normal download.

If you try to use the rs-232 port 1 and leave the usb cable plugged into your computer and the V1210 the rs-232 port will not work until you unplug the USB cable from the V1210.

Going to the new version 9.4.0 has been troublesome for V1040's and V570's, I have had to do an OS update several times with rebooting the PLC's to get it to finally take.

Hope this helps

Deke aka(DonH)

Link to comment
Share on other sites

Hi Deke,

Let's clarify those issues:

If you connect the mini-USB cable, PLC's COM1 RS232 RJ11 will be disabled until you unplug the mini-USB.

For more information you can read the help menu topic in VisiLogic.

Now regarding the new keyboard in V9.4.0:

To solve such problem with V9.4.0 and V1040/V1210, you must perform the following steps:

· Download the latest system files (O/S, BinLib. BOOT) via
COM port RS232

· Download a blank application

· initialize & reset the PLC

· Open your project and restore the system images in system images menu

· Perform build all from "build" menu

· Download your project

Explanation why you must perform these steps:

As it mentioned in the version changes, V1040/1210 get new numeric keyboard so the system images has been changed.

That’s why you need to download a blank application which also download the good order and updated system images.

I hope it helps....

Link to comment
Share on other sites


I have a V1040, OS v3.6 (3). I created most of the project with 9.3.1 build 0. Someone made some changes recently, but since the changes were made the Keyboard opens up transparent. You can see the outline of the buttons as you press them. But the buttons are not visible. I assume the project changes were made with 9.4.0.

Would this be the case? And can I solve the problem by carrying out the suggested actions above 'regarding the new keyboard'?




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...