Jump to content

Splash screen

Recommended Posts


I have a program in a V1210, using a splash screen as a startup screen.

For testing purposes on the ladder code outside the machine I prepered the displays in the program to fit in a V570 and downloded this program.

I have forgotten to remove the splash screen. The V570 accepts the much larger splash screen format when downoading.

After reboot, the V570 gets stuck and will not pass to OS. It keeps on trying to load the splash screen; not succesfull.

Is there a way to clear the flash memory holding the splash screen? It is not possible to load a new empty program since the PLC is not entering the OS.

Also the info mode is not accesable.

Any sollution, please let me know.


Link to comment
Share on other sites

Hello Saragani,

Thanks for the fast reply.

I have tried this aswell.

The OS stop mode is not possible, since the splash screen needs to be loaded before any OS.

I even tried to load an older OS, not supporting the splash screen using an older version of Visilogic.

This older version lets me run the PLC without any program, but loading an empty application gives the error that the version of OS in the PLC is not compatible.

Going back to Visilogic 9.4:

With the PLC trying to load the splash screen holding the screen for ~5 seconds brings me to countdown to OS.

Tapping once brings me countdown to OS stop. => bringing me to the same situation of trying to start the splash screen.

Starting above situation tapping again also at countdown to OS stop gives me the BOOT mode.

Only in this situation communication through Visilogic is possible.

From here downloading an empty project gives the error:

This operation could not be completed. Install an operating version ... etcetera.

When checking the OS, everyting is up to date.

Any other sugestion?


Link to comment
Share on other sites

Hello Saragani,

I have succesfully restored the PLC.

I used Visilogic Version 7.

Downgraded the PLC, only this time complete including the bin lib and boot.

From here I downloaded an empty application.

This took several retries and reboots, but eventually the empty program was in.

After this I went back to Visilogiv Version 9.4.

I upgraded the PLC to the current bin, boot and OS.

From here the PLC was working again.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

This site uses cookies. By clicking I accept, you agree to their use.