Jump to content

Advanced Webserver causes PLC to reboot when go online

Recommended Posts

  • MVP 2023

This post is not a question but rather a tale of pride and stupidity on my part. I hope to help someone in the future to not make the same mistakes I did.

I recently tried to modify the Advanced Webserver to add Modbus IP communications. I decided to re-assign the sockets to my liking.

I assigned Socket 0 to the webserver, Socket 1 back to PCOM, and Socket 3 to Modbus IP. After downloading the program serially I found the Webserver didn't work anymore and the PLC either rebooted or stopped completely with ladder error code 38 when i tried to go online via Ethernet.

Oh, by the way, I also re-assigned the protocol for port 80 to HTTP when I made the new Socket init block.

Talk about maddening. After several hours of trying every combination I sent the application to support and got Ryan's help.

Final Conclusion:

The Webserver app absolutely positively requires Socket 1 be initialized to protocol TCP_RAW, port 80. This exact configuration is required by the locked subroutines.

To get online I initialized Socket 0 to TCP, port 20256, slave. I set Socket 3 to TCP, port 20257, Master for my Modbus IP communications. Everything works as it should now.

Joe T.

  • Upvote 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...