Jump to content

Recommended Posts

I was just playing with the V130 Modbus TCP slave communication. I set everything up and connected through my simulator. Reading holding registers worked fine. However, when I switched to reading coils, I got timeouts. With a bit of playing, I discovered that if I asked for 7 or fewer addresses it worked fine. At 8 or more I got timeouts. However, I could shift the address range up by 7 and ask for 7 more and it worked fine. It is not the addresses, just the number of multiple coils requested (one byte?). This is far below the Modbus spec for multiple addresses. I got the same result on a V350. I have not found this documented anywhere, but it appears to be the intended operation. I don't use the Modbus coils very often, so I may have just never noticed it. Have others experienced this limit?

Link to comment
Share on other sites

  • MVP 2014

I don't recall experiencing this.  Since it sounds like you have a V130 and a V350, I suggest setting one as master and one as slave.  Then see if the limitation still exists when reading from Unitronics to Unitronics.  (Or in general, try it with a different slave, other than the simulator).

Link to comment
Share on other sites

Here are some further test results of multiple coil requests:


Simulator (master) to V130, 350 and 570. Limited to 7 coils. TImeouts occur if higher.

Simulator (master) to HMI panel brand X. No problems requesting up to the simulator limit of 100 coils.

Simulator (master) to PLC brand Y. No problems requesting up to the simulator limit of 100 coils.


V570 (master) to V350. No problems (R.C #1, vector length 1900)   


HMI panel brand X (master) to V570. No problems with 20 tags. However, I have no control over how it acquires them. I believe that because they are sequential it would request multiple coils, but I have not confirmed that.


So the only issue appears to be the simulator (ModbusView TCP from Ocean Controls) combined with the Unitronics Vxxx devices. I have no idea why. This is more of a curiosity exercise since I typically pack bits into registers, rather than using coils. I just stumbled onto it running a quick test of some V130 code, to be sure it was communicating.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...