Jump to content

Recommended Posts

I have attached images to this post below...


Basically I haved a V570 (with the ethernet addon) which was last used about 5 years ago.


When I powered it up, I got a no loaded application error.  I have tried going into visilogic, with with default baud rate settings, and the settings shown on the display, but i just cant get access to it.  I also am using a 4 wire RJ11 cable ( I have no programming cables left).  Could this be the issue that I cannot connect?


Or is it because the PLC is in stop mode?  I have tried connecting via ethernet, but my lan adaptor wont let me use the subnet mask that the PLC is showing (it says that it is invalid).


Many thanks,





Link to comment
Share on other sites



Since the program has been lost due to a complete power failure it will display this message. This occurs when power is removed from the PLC, the battery backup fails, and the program is not burned into the flash memory.


You are not able to connect using Ethernet because it will not have any of the Ethernet capabilities initialized and the controller is not running. Have you tried connecting using a serial connection through VisiLogic?


Once you are able to establish a serial connection through VisiLogic you will be able to re-download your project and it should then operate as expected.


I would also highly recommend checking to see if the internal battery has gone low. You can check SB 8, if this bit is on than the battery must be changed. If the battery is dead and power is cycled it will likely lose the program and any retained operands again. Another solution is to burn the project into the flash memory of the controller which will retain the project even in the event of a complete power loss.

Link to comment
Share on other sites

Thanks for your reply,


At least I know to not bother with ethernet!


I have tried serial connection, but I only have a 4wirecable rather than a 6 wire programming cable you get initially (they are all out on our systems at the moment).


I have looked around to see if 6 wire programming cable is required, but I havent had any definate information on that.


Do you know if me using a 4wire cable at the moment could be causing the issue that I cannot connect to it?  In the meantime, I will check the backup battery, and see where I can buy a 6wire RJ11 cable from.



Link to comment
Share on other sites

Having only 4 wires shouldn't be a problem depending upon how it's connected. The RJ11 port can utilize 6 pins, but not all simultaneously. Pins 1 and 6 are used for RS485 and pinout is as follows:


Pin 1: A signal (+) 

Pin 6:  B Signal (-)


RS232 uses pins 2-5 and the pinout is as follows:


Pin 2: 0V reference

Pin 3: Tx Signal

Pin 4: Rx signal

Pin 5: 0V reference


Our standard programming cables do not utilize pins 1 or 6. Either configuration should work depending on how you have the wiring hooked up. This information can also be found within the V570 installation guide without the Technical Library on our support page.

Link to comment
Share on other sites

Thankyou, thats good to know. ( I have plenty of those cables)


I think I have lost this battle though:


I cant conenct via serial at all.   I managed to get ethernet connecting, but I couldn't upload projects due to operating system mismatch.


I then made a clone file with OS in visilogic, started up the PLC in boot strap mode, and then did a firmware update based off the clonefile.


This seemed to update the OS, but now when I try and upload my projects via ethernet, my PLC locks up. I think this PLC must be faulty.



Lastly:  When I try and do a firmware update within visilogic (I have a enchanced V570), I get a "OS you are downloading not supported by the versions of boot/bin.lib" error.  I cant manually force it to update the boot files, as the option is greyed out.  I did the live update of the OS version before doing this.


Updates of applications via SD card results in a lockup of the PLC also.

Link to comment
Share on other sites

Which version of VisiLogic are you currently using and which project or O/S version is currently in the controller? If you are trying to upload a new project into an older version of VisiLogic it will not work as expected.


At this point it sounds like the O/S could have had some issues updating and you would need to perform a reinstall.


The O/S, bin, and boot files must all match and can not be used with different versions as they will likely cause compatibility issues.


How did you attempt to perform the O/S upgrade? If you try to perform an O/S update through an Ethernet connection it can cause problems since the bin and boot files controls how the card operates. In order to perform a full O/S, bin, and boot file upgrade it is recommended to use a serial connection.


When trying to connect to the controller via serial you can put the controller in bootstrap mode to download a new operating system. This allows only basic communications but should allow you to connect in order to upgrade the operating system.


To put the unit into bootstrap mode press and hold your finger on the screen, then while still pressing the screen cycle power. Right after power has cycled you can release pressing and tap the screen twice to put the unit into bootstrap mode. At this point you should be able to establish communications with the unit. 

Link to comment
Share on other sites

Hello Alexander,


Unfortunatly serial comms is something that no one has ever got to work with this controller.  I have managed to make it work with some V350s I was setting up before, but this older V570 left over from an older project was one where the people originally working with it only ever managed to get working with Ethernet.  Its not helping that I need to use a Serial via USB adaptor, as that adds an extra layer of potential problems on the situation.  Fewer and fewer computers come with built in serial now, I would love it if all the controllers worked directly via usb! (baud rate checked, RS232/RS485 checked, cable is a 4 wire RJ11, drivers for usb/serial updated, using port1)


Realistically I have spent too much time on this allready, it could just be down to a faulty/incorrectly installed USB/Serial converter, but I am going to have to knock it on the head.  When the project goes ahead, I will have to buy a new PLC.


Thanks for your help though

Link to comment
Share on other sites

I myself also use a USB to serial adapter. It could be Windows settings, drivers, or the cable itself that is causing you difficulty connecting to the controller. If you do end up trying this method you can rule out 2/3 by using these recommended settings below:


  • Make sure UAC is disabled when running Windows Vista, 7, or 8
  • Running UniLogic as an administrator is also recommended. This can be accomplished by right clicking on the UniLogic icon, choosing Properties, going to the Compatibility tab, and selecting the box labeled Run this program as an administrator.
  • You may need USB to serial drivers. We recommend using the Prolific USB to serial drivers that can be downloaded from the Prolific website. http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=225&pcid=41

If you are still unable to connect it could be the USB to serial converter, programming cable, or as you mentioned it could also be the COM port though it is less likely.


If you do end up narrowing down the issue after ruling these settings out you can always call tech support for assistance in potentially replacing the unit if it is still under warranty.

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...