Jump to content

Data Tables filled in and stored in PLC, but can't be read

Recommended Posts

Dear all


i can't read my datatable, I'm trying to read out a certain row but it doesn't come into my variables.

I use the function "Data Tables Read Row"

First I tried to call this function with a ladder normal open contact and now I put it directly at the left side, so it should continuously read-out my table 'Presets' and place it in the variables.

In online monitoring mode this function is called (marked in red) but the variables from the preset table are not placed into my local variables.


Can't find the fault.


Anyone some suggestions for me what to check?





Link to comment
Share on other sites

Thanks for the help.

I tried to split out ladder/nets.


However my problem was not solved.


I really had to restart from scratch and I started with my problem of datatable reading as a first thing to examinate.

Now it works.  I continue to build up step by step to finally reach my old program.

It is a lot of work, but it will be the shortest.

I programmed to much at once without controlling step by step.


I'm using Windows 8.1 and sometimes Uintronics shuts down.  Maybe there are some issues during compiling? I really don't know.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...