Jump to content

Issue Windows7 - TCPIP - Download projects

Recommended Posts

Dear all,

I have been a reader of the old and new forum since 2007, when I installed a V570 in my living room as my home domotics controller. I found very usefull information on the forums in the past.

Anyway, would like to post following issue after upgrading to V9.0.1

Pre upgrade situation


OS 2.1

Boot 2.01

Programming pc : Windows 7 x64 UAC ON - Visilogic

Always was able to download projects to the plc via TCP/IP

After upgrade situation



Boot 2.2

Programming pc : Windows 7 x64 UAC ON - Visilogic 9.0.1


Not able to connect to plc via tcp/ip -

Not able to get oplc information via tcp/ip - communication driver error (210) - not able to establish tcpip connection


* Upgrade to OS3.3 was done via a 2nd pc (not programming pc) Win7 x32 UAC ON , because that one still had a serial port.

Clean install of Win7 x32 , clean install of visilogic V9.0.1.

Same issue with tcp/ip, upgrade done via serial, download projects via serial = ok

* PLC has the correct plc name as in the project, and has socket 1 set to port 20256; projects inits tcp card and sets plc name

* On the programming pc (win7 x64) tried the following :

- packet sniffing as specified in topic http://forum.unitronics.com/index.php?/topic/102-ethernet-connection-v570/

- ping to plc - works

- access webserver on plc - works

- followed instructions as specified in the pdf in another forumpost : turnoff uac, deinstall, remove folders in progam files, common files and appdata/local/virtualstore, reboot, reinstall - to no avail.

As a last resort installed V9.0.1 in a WinXP virtual machine on the same Win7 x64 programming pc. Works right off the bat via tcp/ip. This proves to me that the plc and project are correctly configured, and the issue is due to Win7 installation.

Any tips on how to get it to work in native Win7 ?

Kind regards,


Link to comment
Share on other sites

Thanks for the suggestion.

I rechecked just now : UAC was already off , I turned off Windows firewall, and don't have any virus scanners or similar software.

I reinstalled again : deinstall, remove folders in progam files, common files and appdata/local/virtualstore, reboot, reinstall - to no avail.

A cross cable connection is a little difficult (due to location of plc and pc's) but since I can do "get oplc information" via tcpip and download projects from a xp virtual machine with v9.0.1 on that same windows 7 pc, I doubt that it would be a network issue. The plc and pc are on the same switch, no additional network hardware between them.

Anyway - I have a workaround through the xp vm; but still suspect that this is an issue with v9 and win7; the same win7 x64 pc (with uac, firewall on, ...) connected perfectly via tcpip on V7 prior to the upgrade.

Link to comment
Share on other sites

  • 1 month later...

Just wanted to update that the issue has been solved :

Apparantly it has something to do with the existing project.

I opened up a new project today on one of the Windows7 machines, and pointed the tcp/ip project setting to the plc. I could connect on first try.

As this worked, I tried the same in the existing project - deleted the information in tcp/ip project settings, and added the same information back again.

Now I can connect over tcp/ip on all 3 machines (win7 laptop/desktop and the xp vm).

I didn't come up with this sooner as I could connect from the XP machine with the same Visilogic version...

Link to comment
Share on other sites

  • 2 months later...

Am having some major comunication problems with Windows 7 Pro 64 bit over TCP/IP and Vision 130, Visilogic 8.6.3....Did all the programming and testing form my laptop running XP pro, no problem whatsover. Installer VL 8.6.3 on Win 7 PC, and copied program accros. Had coms via TCP/IP but all of a sudden lost it. Can still ping the PLC, vislogic reports a coms failure error. Also uses Zview scada, lost coms at the same time.

Uninstalled all antivirus software (Kapersky 2011 IS) Did system restore to before I coppied program. Had coms for ± 5 minutes....all coms gone again...except ping. I suspect something in Windows 7 is blocking it. Have set UAC to lowest level, also gone to the program folder of visilogic app and right click-. run as administrator..not luck. Saw that a critical windows was installed at more or less the time I lost coms. Ran system restore again...still no luck.... Any ideas?

Link to comment
Share on other sites

Did a system restore this morning. All worked fine, coms with VL 8.6.3 & Z VIEW. Finished some charts on ZVIEW. Worked fine for ± 1 hour....all coms lost again, except ping still works!!

Had enough of Win 7's PMS-BS, formatting and reloading XP Prof

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...