Jump to content

290 DL issue with OSv5.04

Recommended Posts

We are having a few issues D/Ling a piece of our code to the vision 290 PLC's.

We have OS5.04(B13) on the PLC which matches the OS5.04 (we not sure of build match though) the code uses.

It gets to 91% via Serial or TCP/IP and then looses its connection.

We have tried using Visilogic 9.01, Remote access 9.01 and remote access 6.01 with the same results.

Its D/Ling a piece of our code using OS4.72(B26) well with no problems.

We also have a PLC that won’t respond to the tap trick and stays loading in Boot Strap Mode (I suspect due to the above problem).

We can get the info about its OS etc from the PLC but it will not DL or communicate more than that.

Does anyone have any ideas – we are getting stuck fast.


Link to comment
Share on other sites


First, Go to VisiLogic help menu and update the O/S from the web.

Then open your application and make sure to use the following communication parameters:

  • Baud rate - 57600
  • Time out - 6 sec

Go to connection menu>communication & o/s > Operating system tab and check for the latest o/s.

Download the application again.

if you have the same problem, go to Project menu and create a dvi file (for UniDownloader)

go to Tools menu>UniDownloader Designer>and import your DVI file to UniDownloader project.vlp only, no o/s needed.

Then download the UDC file to the PLC

Let us know if it helps!

Link to comment
Share on other sites

Thanks for the help.

I already had the lastest version OS but checked again anyway, I then attempted to download the application using Remote Access with the following communication parameters:

  • Baud rate - 57600
  • Time out - 6 sec

The download failed at 91% as before.

It seems as if the controller was resetting itself twice, and I lost communication on the second reset.

I created a UniDownloader UDC file with the application only (no o/s).

Then downloaded the UDC file to the PLC - it worked.

I did this to two controllers with the same results each time.

I am happy its working but should it work with remote access?

Link to comment
Share on other sites

  • 2 months later...

Sorry its taken a while for me to get back.

We are using the unidownloader for technicians in the field so we are able to operate ok.

The blank .dvi application works no problems with OS5.04B18 & B20.

The issue only appears with our application on both OS5.04B18 & B20.

The issue does not appear when we make a unidownloader file with the troubled dvi in either OS.

Therefore I think the problem may be somewhere in our application, but why do both the unidownloader and visilogic work?

I have inherited this code but I am more familiar with it now. Having said that I cannot solve this issue.

What are your thoughts about how to go about solving it?

It’s not urgent but we'd like to solve it as remoteaccess is our primary tool for technicians.

Kind Regards


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...