Jump to content

Unistream Error Writing File to a SD card


Recommended Posts

Hi there,

I am trying to write my DataTable to SD card using Store DTI to file function,    but always get an error.  Error code -4, thus Internal Error. Contact support.

So I have tried to download an official example, called Unistream_070_Indexed_Data_Table to the PLC, but it does not write the file as well, but the error code is -6 Write file error.

I have tried SanDisk Ultra 16 GB  and Kingston  CanvasSelectPlus 16GB, both formatted to FAT

I have also tried to Run UniApps, File Browser and copy some file from USB flash disk to SD card, that worked

DataSampler files are written succesfully to the SD card and there is no problem

So assuming the PLC recognizes the SD Card properly.


Versions info: PLC bins: 1.30.51 from Oct-25-20

UniLogic version: 1.30.62 activated

HW configuration:

- PLC: US7-B5-B1




Note that the expansions cards are not physically connected to the PLC as I am developing the software on table, the plc will be included in the switchboard later






Link to comment
Share on other sites


As there was no reply, I have contacted support..., but thanks to the Czech distributor's employee Mr. Roman M., who took my program and tested it on another PLC, where it worked. So I updated the firmware and Unilogic to the very latest version from Jan,6th and it works now!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...