Jump to content

State of MB's after changing program

Recommended Posts

Hi Folks

I have a V1040 that i use as a spare and for testing.

I am not a programmer but tend to play around with it to try out new functions.

Recently I loaded a new program on the controller replacing the existing program.

I set up some simple buttons on the main screen with jumps to other screens.

Some of the links worked but others would link to the wrong screen

For example i set up button 1-4 to link to screens 1-4.

1 and 2 would jump to screen 1 and 2, but 3 and 4 would also jump to screen 1 and 2.

I then noticed that many MB values were set at 1 (even though they were not in use).

I assume these were set in the old program.

While this is not a problem normally as the ladder logic will reset them to the correct state, it causes a problem with the touch element as many show on when the button is not pressed causing the program to jump to the wrong screen.

This was the case for button 1 and 2 above, the MB stayed on so every time i touched 3 or 4 it also saw 1 and 2 as being touched.

The MB assigned to each button was not used anywhere else in the program.

I tried downloading a blank program but the MB state remains on and will stay on even when linked to a touch element.

i have the latest operating system in the controller.

Is there a way of resetting the controller to factory state with all MB values at 0 before loading a new program.

Apologies for the long winded question.



Link to comment
Share on other sites

I must say that I never expirianced the problem you mentioned (MBs that are connected to a button stays set after linked to a touch element).

You are correct that values of operands is preserved, this is intentional. You can however force initialization of values by either Power-Up values (that will require you to set an initial value to each operand), or using the communication config where you have in one of the tabs an option to Start, Stop, Reset and Init the PLC. If you Init the PLC, then it sets all operands values to 0 and restarts the PLC.

I encorage you to contact the support team and report them about that bug. I hope they will be able to reproduce it.

Please don't forget to supply OS and Boot versions that are installed on your V1040 PLC.

Link to comment
Share on other sites

Thanks Saragani

What I have found that if I download a blank program to an V1040 that has had a previous program, that many of the MB values show 1 on the online view (even though there is no program in the PLC)

This is normally not a problem as when the MB is used in the ladder, after the first scan the value is set to 1 or 0 according to the program.

However if this MB is just linked to a button for jumping to another display and is not referenced in the ladder, I see that the MB stays at 1, causing unpredictable jumps.

As soon as I use a different MB the problem is solved.

Hope this clarifies the problem.



Link to comment
Share on other sites

  • 3 weeks later...

The last time had issues with memory in Visilogics was a couple years ago.

Visilogics did not clear all memory when loading a new program.

The memory is not initialized.

Not even a new PLC had the memory initialized.

This was very annoying when you try to make a production product.

The production line can load the program, but it wont work until the memory is cleared, or the behavior will be erratic.

I made a small subroutine that cleared ALL the memory in thee whole PLC. Then everything worked great.

If you go online with a new one, you can scan the memory and see some of the memory locations have data.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...