Jump to content

Recommended Posts

Hi @ all,

I have just a short question about the hardware of a V260-16-B20B.

When reading the installation guide, there is stated, that the COM2 Port could be used either as RS232 or RS485 port.

One should be able to choose if it's 232 or 485 by changing jumpers on the inside of the OPLC, right next to the COM-Ports.

As I opened the OPLC to install an Ethernet-Card on Port3, I wanted to change the COM2 Port to RS485 by jumper selection, but there is none ....

So, is it not necessary to have jumpers switched on V260-16-B20B or is it not possible to use it for RS485 Modbus Communication on Port2 ???

Thanks to you guys,


Link to comment
Share on other sites

OK, thanks for the info, Simon.

Let's assume i put an external converter RS232/RS485 (bidirectional) inbetween. Do I have to change my code concerning modbus RHR and PHR and so on? Or is it just changing the port setting from RS485 to RS232??

Could I use the programming cable to connect to that external converter?

Any suggestions on that?

Reason is: at this V260 there was a V200-19-RS4X installed for the RS485. We replaced it with a V200-19-ET1 to have better remote access to the PLC. Now we face the problem of having no ModBus Communication to the 3 external devices we want to gather data from....

Thanks for your help, it's much appriciated

Link to comment
Share on other sites

  • MVP 2014

For selecting between RS232 and RS485 you only need to change the mode in the COM_INIT block. The Modbus functions (RHR, PHR, etc) do not change.

Also make sure you change the Modbus configuration block to point to the new COM port.

Unitronics have a convertor (I should have posted that in my previous post). It allows you to use the programming cable and just plug it into the PLC and convertor. The convertor has an RJ11 socket that is pin-compatible with the socket on the PLC.

Part Number M90-19-R4


Just check that this convertor meets your needs, note the supported baud rates are 9600, 19200, 38400 bps.

If you need to use another convertor, they are available in a variety of termination types, such as DB9 and screw terminals. The cabling required will depend on the convertor.

Link to comment
Share on other sites

  • 4 weeks later...

Hello Simon,

once more it's me.

So I tried with a RS232/RS485 converter. It's a device from third party, which allows powering from RS232 and optional powering from another source (it's USB as it's built to connect a PC to e.g. a ModBus-net).

So after about 2 hours of trying with no results, I changed the complete setting from COM2 to COM1 on the PLC and after the PowerUp, it was running .... at least for 10 seconds (the read acknowledgement counted till 26) and it was gone again....

What was very confusing to me: when watching the slaves (3 in this case) I could see that the slaves receive the messages (the RX led there lights up periodically) and also start answering when it was a message for them (TX led starts lighting directly afte the RX). So, the nodes answer, but the PLC don't recognise it. At first I was thinking, maybe it's aproblem with the powering from RS232, but there was no change with the additional external powering. After that I thougt it may be a problem with the pin connections, but as it was working, for 10 seconds, that couldn't be the problem either.

So, is there a buffer I can directly watch when it comes to send/receive (some SDW or SI) ??

To explain the hardware: It's a RS232 to RS422/RS485 converter from "Exsys" (EX-47900). I connected it to the PLC with the programming cable and a gender changer (male/male) and a null-modem-adapter (the slaves got no messages without the null-modem-adapter). On the RS485 side there is double shielded twisted pair cable installed, with termination on both ends. The PLC is in the midst, meaning that in 2-D it would be (termination:slave3 - PLC - Slave1 - slave2:termination). Everything connected with RS485-2Wire.

So if anyone could give me a hint why it's not working, or why it worked only 10 seconds or why the PLC doesn't seem to recognise the answers from slaves, your help will be greatly appreciated !!

best regards


Link to comment
Share on other sites

  • MVP 2023

1. Take the terminators off one at a time and see if it helps. Each terminator lowers the RS485 signal level by some amount and your converter may or may not be translating the data properly.

2. Google "free modbus master" and see if you can find a program to run on your PC to query your slave devices with the RS232->485 converter. You need to verify that your 485 network is wired correctly. I've often gotten A & B backwards (no they are not the same between all manufacturers). You also need to verify your baud rate and parity settings. I've found this much easier to do on a PC.

Joe T.

Link to comment
Share on other sites

  • MVP 2014

Ditto for Joe's comments. it sounds like you are close, the problem seems like a data integrity issue, either with the RS485 termination, baud rate or framing. I didn't look up the 232-485 convertor, but is it one that auto-detects the baud rate and framing or does it have DIP switches or jumpers?

As for internal status values in the PLC:

SI274-276 Received message counter, serial: may only increment on receipt of a full message, you will need to check.

As Joe suggests, try to get a PC on the system, so you have a lot more capability to see what is happening.

Link to comment
Share on other sites

Joe, Simon,

thanks for your advices so far. When I'm able to go to the site one more, I will try this out (even though I already tried with one terminator off without success), but we'll see.

Concerning the part of having A und B signals inverted somewhere:

As stated in first post, the exactly same cabling was used to communicate ModBus to the slaves with the V260 before, but with a RS485 card installed at COM3, which now has been removed for Ethernet-card on COM3.

As it was working back then(at least 70% of the time, as long as the ModBus function was processing the read operations, but went to fault at the write operations randomly) I assume that this is not a cause of trouble. Also as stated, when trying to change A and B signals at the converter, nothing is received by the slaves - I love RX and TX LEDs on communication devices ! ;-)

But however, I will try everything that may help me. (Got myself two different ModBus Master software freeware versions for testing now).

But I have to wait a little bit, as I don't want to visit the site without another (completely external powered) device, as it's everytime a trip of two hours - one way - which nobody is gonna pay to me if failing again...

Will get back to you if I know more .. or less .. or whatever ...



Link to comment
Share on other sites

  • MVP 2014

Since you mention that even in the previous configuration there were some failed operations, then it opens up the need to check more aspects.

  • with your program sequence are you allowing time for one operation to complete before starting the next (using the modbus "Function in Progess" bit)? You may also need to insert also a small delay between operations, of 100ms or more, to ensure no bus conflicts. Since RS485 is half-duplex, the transceivers need some silence on the bus to change from RX mode to TX more (or vice versa). I suggest this because you say you had some failures even before this recent change, when using the write operations.
  • What is the length of the RS485 network?
  • What is the cable type used?

Link to comment
Share on other sites


as for your questions what I can say so far:

- the read operations have never been a problem in the old installation, only sometimes the write operations

- in the ladder software, there is used before every operation a negative contact of "Function in progress"-Bit, after the "Read Holding Register" function for example, we jump to another step, where a counter is incremented if the Function in progress bit is negative and with the positive contact of SB15 (100 ms coil), until counter reaches 20, then we go to next function (read or write), so the time delay to wait for an answer should be long enough. That's also easy to follow up, as the MI for Status Messages is "4" at first, then switching to "5", after going to the next operation starts with "4" and so on...

- cable length : Slave3 - 20 meters - master - 23 meters - slave1 - 4 meters - slave 2

- cable type is double shielded twisted pair, all the same type, no mixing. If you want to know the exact name of it, I can tell you after I have checked on site. But as we use this cable all the time for the ModBus directly over RS485, and never had problems with it, I personally don't think that this really could be the problem.

Thanks for the detailed questions and advices so far, as mentioned before, I will go test it further when having another converter and going to the site to investigate some more.

best regards


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...