Jump to content

O/S version 0.(0) during download?

Recommended Posts


I got v560 and VisiLogic 8.6.3 installed...

During download I have message O/S Version 0.(0) and warning (220) that "newer O/S version is required."

In Info menu software version it says:

firmware:003.001.30 (Nov 14 2010)

boot: 002.002.02 (mar 8 2010)

bin lib: (1) 001.003.04

Factory boot:001.003.01 may 16 2010

In VisiLogic /Communications-PC settings... O/S Check/ offers no upgrades (see attached screenshots)

PLC starts normally with last downloaded application but I can't download anything new

post-382-039726800 1294180456_thumb.jpg

post-382-071123300 1294180770_thumb.jpg

Can you help me with this issue? (how to restore normal download)

Thank you

Marko Kocijan



Link to comment
Share on other sites

  • External Moderators

Hi Marko,

This could quite possibly be caused by the Vision 560 being shipped with a Newer O/S than VisiLogic.

Best idea is to Open up VisiLogic and click on the "Help" Menu -> "Check for Updates" -> "Operating System". This will insure you have the Latest O/S ready for Downloading.

Try to Update the PLC's O/S again. If it fails with the same error, then try the following:

On the "Install Operating System" tab (Shown in your first screenshot), click the "Check Button". It should tell you that the O/S is up to date and there is nothing to Download.

I haven't got any PLC's on hand at the moment so I can't explain this exactly... but somewhere there should be a Button called "Advanced" or Similar.

Click that button and you should be presented with three boxes for selecting Files. Here you can select an O/S, BOOT and BinLib to Download.

On each box just click the Browse Button (Usually "...") and select the File you see with the latest version number...

Hopefully you can figure out how to get to the "Advanced" Page and download the correct O/S to work with VisiLogic 8.6.3


Link to comment
Share on other sites

Hi Ash,

thank you for the fast answer...

I already tried upgrading using "advanced" tab.

When I use this method, I loose serial communication after "Erasing" od old O/S.

"Erasing" progress bar comes to end, PLC changes from "erasing" to "idle" /SM request and after few seconds PC displays that comm is lost and I can't do anything until I power down/up PLC again.

I got O/S error on next PLC boot but then communication is established again, I can "check" OS version and load O/S using "wizzard"

This "normal" (wizard) upgrade works fine but again when I want to download application, download fails with O/S 0.(0) error.




Link to comment
Share on other sites

  • MVP 2014

Hello Marko,

Quick question: are you using 115,200 baud? This is required, as the enhanced series PLCs always revert to 115,200 baud once the OS has been erased.

Also, try powering down the unit, removing the battery and leaving the unit powered down for at least 30 minutes. Then power up with your finger on the (i) key, and try the OS update again. Once all is well you can put the battery back in.

DISCLAIMER: I haven't yet powered up a V560 for myself, so am assuming it behaves the same as its cousins.

  • Like 1
Link to comment
Share on other sites

Hi guys,

thank you for help here...

yes, I use 115,000 from the beginning. Powering down unit and leaving it without battery whole night didn't help. Unit started in the morning with all data inside, including application I downloaded last before "problems". Good hardware :-)

Well, support gave me 9.0.1 beta which behaved same as 8.6.3 and 9.0.0beta. No progress.

Powering up in bootstrap mode (hold 5sec after powerup and taping twice to stop initialization) also gave me no results.

I even took another PC to check if PC is the problem...same thing.

Then I installed v8.0.1 and put older OS for v570 into the unit.

After that, 8.0.1. was able to "download" application to PLC. :-)

I installed 9.0.1 again and upgraded OS only through advanced menu. It worked! New OS 3.3 (03) was installed ok and unit reported it correctly during application download.

But I wanted also to upgrade BinLib and Boot file....(through advanced mode)

Here I noticed that I loose serial communication BEFORE BOOT or BINLIB system files are erased ("erasing" progress bar remains empty and PLC shows "Idle" on the screen)...PC reports loose of communications.

Only when I choose O/S file to be downloaded, erasing bar works, plc changes from Idle to Erasing and Programming etc. New O/S is installed correctly and download of application works again.

Well, I'm still not happy because if I go to PC communication...O/S check...VisiLogic opens upgrade dialog and wants to upgrade BOOT, BinLib and OS to latest versions (newer than currently in PLC)...but when I start (4 steps) wizzard, it starts erasing O/S system files and serial communication breaks when O/S erasing bar reaches the end.

Powering down/up PLC results with "O/S error" but then using Advanced mode I download only O/S file and restore the unit to working condition.

Same thing happens on both my PC and laptop so I don't think is specific PC related issue.

At least I manage to avoid reporting 0.(0) version at beginning of application download.

If you know a way you can upgrade BOOT and BinLib files without communication break, it would make me happy :-)

Thank you again for helping me along this problem



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...