Jump to content

cannot export subroutines

Recommended Posts



I'm using Visilogic 9.7.24 build 0 on a Win7 pc. I want to export a subroutine. When I select the subroutine and choose a locotion to copy to all works well, until i hit save button. I then get the message: This subroutine cannot be exported because it contains illegal characters. (Visilogic 329). What is going wrong?

Link to comment
Share on other sites



What are you trying to name the file when you save it?  Would you be able to share a picture of the error message you receive?


Also, are you running the program as an administrator?  Running as an administrator ensures our software can properly run with no restrictions, and can sometimes solve peculiar issues.


Run As Admin

Link to comment
Share on other sites

Hi guys,


Problem is solved. Thanks for the help.

I tried to save the subroutine all the time to a networkshare. This share has an awful long name. I did try to save the subroutine to the local d:\ drive in a subdirectory and it worked.

I'm wondering why I can't export subroutines to a networkshare with a long name and I do can save a program to the same networkshare.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...