Jump to content

Gadner Denver Compressor Com Module

Recommended Posts


Trying to connect to a Gardner Denver   Airsmart  Controller Comm Module.

Serial Interface - RS232  works.

Trying the MODBUS  TCP  UDP  protocol on their ports 2000 and 2001 - no luck yet,  we can ping the IP OK, just no connection for

MODBUS Read Registers(3)

Any one had experience with this unit?




Link to comment
Share on other sites

  • 2 months later...

I am having a similar issue. Using Prosoft Modbus Ethernet card for compactlogix and Gardner Denver AirSmart Controller Comm module.

I can ping the comm module, but I get a error code -48 when I try to read from the module. It is the same error as if it was not connected at all.

I have tried different cables, and bypassing the ethernet switch.  What else do we have to do with the AirSmart comm module other than enter the IP address, subnet mask and gateway.


Link to comment
Share on other sites

For these tasks, a reliable modbus simulator for PC is absolute priceless thing. If you are in doubts, the first task is to check the setting with simulator. It is much easier to find problems if you can change the communication parameters interactively "on the fly" without changing, compiling and reloading PLC program. When the device communicates with PC without bugs, then it is the right time to start comunicate from PLC. 

Good luck,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...