Jump to content

JZ20-J-R31 Communication Problem

Recommended Posts

I have problems communicating with the JZ20-JR31. 

I am using a usb connection (Port COM 10). A serial connection is not an option for me at the moment. 

So, I manage to establish connection via Controller --> M90 OPLC Settings --> PC Communication Port Settings --> Get Version.

Then when I try to download the program it looses connection. 15 minutes ago I was able to download the program but it would still loose connection every 2-3 seconds or so. 

Now It won't even connect. 

I tried running U90 as administrator, Nothing.

I tried changing USB ports, Nothing. 

What else should I try?



I am using windows 7.

Link to comment
Share on other sites

Once I ran into the same problem with a JZ20-J-R31. I could solve the issue when I noticed that the PLC had changed the communication settings back to defaults (9600 baud, Parity Even, StopBits 1, DataBits 7).

Go to your windows settings for the com-port and check the settings (in most cases: Baud 9600, Parity: None, Stop Bits: 1, Data Bits: 8, Flow control). Then go to the U90 Ladder programm -> Controller -> M90 OLPC Settings, press the "Adcanced" button in the "Settings" section, adjust the settings to your windows settings and press "Set PLC Settings".

For me this solved the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...