Jump to content

Can't connect to v570 via ethernet

Recommended Posts

  • MVP 2023

I'm suddenly having a problem that I can't figure out. I hope someone can provide a few tips. I am trying to connect to a couple of v570s via ethernet from my laptop. I've never had a problem doing this in the past but suddenly something is broken. I have two v570s successfully talking to each other through an ethernet switch using MODBUS IP. When I connect my laptop to the switch I can ping either v570 successfully, but I cannot connect to either using VisiLogic. I have the PLC Names set properly, have the correct port number, and IP addresses entered into the communication box, but no go. Here is the setup on each PLC:

PLC Master - Socket 3 initialized to Port 502, protocol TCP, Master, for PLC-PLC com (IP Address

Socket 1 initialized to Port 20256, protocol TCP, Slave, for PLC-PC comm

PLC Slave - Socket 2 initialized to Port 502, protocol TCP, Slave, for PLC-PLC comm (IP Address

Socket 1 initialized to port 20256, protocol TCP, Slave, for PLC-PC comm.

PC - IP Address set to

All three are set to for subnet mask, and for Default Gateway. System bits on both PLCs show both sockets on each PLC to be initialized, as well as the ethernet card.

I'm sure I'm overlooking some silly little thing - what is it?


Link to comment
Share on other sites


Are you sure this is the right gateway?

Did you try to connect the PC to one of the PLCs directly and test the communication?

Anyway please try to disable any firewall, antivirus or any other program that might block the connection.

Link to comment
Share on other sites

  • MVP 2023

Thanks for your reply. Since I'm not connected through a router or network, I'm not sure the Default Gateway really matters, but I've tried a number of different settings, all to no avail. The two PLCs and the laptop PC are connected through a digital switch, not a router. I've also tried connecting the PC directly to one of the PLCs with a crossover cable, but that doesn't work either. Again, PING works fine, just can't connect using VisiLogic.

I have no anti-virus or firewall running right now (not connected to the internet) - any other settings I should be looking at? What are the minimum requirements to connect VisiLogic to a PLC via Ethernet?

-PLC Name

-PLC Port #

-PLC IP Address

-Protocol: TCP

-Socket initialized to TCP Slave

-PLC & PC on the same subnet

Those are all I can think of and I've checked and re-checked all these items. What am I missing?

Link to comment
Share on other sites

I've had success in using MB3 in the following attachment to reset ethernet. Useful when you have just changed parameters. Connection drops when you toggle MB3, but seeing as you have used a -|P|- contact, you can just reconnect.

If you use a -| |- contact you disable ethernet!

post-193-075018300 1307656754_thumb.jpg

Link to comment
Share on other sites

  • MVP 2023

I fixed my problem by changing everything to the 192.168.1.xxx subnet. This tells me that the problem was due to some sort of firewall running on my laptop that wasn't allowing access to the 10.1.1.xxx addressing. I cannot find any firewall running on my laptop, so I'm not sure how to fix it, but the problem appears to be within my laptop (though why did PING work?) and not anything to do with the PLC. Thanks, Ofir and Ziwi, for your attempts to help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...