Jump to content

EX-RC1 and IO-DI16A3-RO16 output problem


JOTA

Recommended Posts

Hello:

 The first step to connect and IO module is to test communication between both equipments. I downloaded the EX-RC1 communication program that comes with VISILOGIC help, erase the IO that comes and add my IO, compile and transfer to the EX-RC1.

While testing, I wired the first 3 inputs and, while online, checked activity at the VISILOGIC and works fine (so communication and configuration seems to be good). Problem happens while testing OUTPUTS. In VISILOGIC i force the OUTPUTS but they do not respond at the IO Module.

Diagnostic lights are green and steady, so they indicate everything is fine, but outputs does not work. 

 

Any suggestion is appreciated.

 

Joaquin

Link to comment
Share on other sites

Hello Joe:

 

Thanks for your time and effort for helping. 

Attached is a program without CANBUS communication, some photos (sorry, cannot upload video). This is the way I have tested in the past and it worked . 
 
In photos you may look at the installation. The equipment is connected to a power supply, and you can see an EX-RC1 and the IO module. Also you may look at the diagnostic LED that shows correct communication. 
image.png
 
It should be simple. The EX-RC1 is a CPU. If I connect a CPU to my IO´s I should be able to receive feedback from my inputs and control my outputs.
 
Right now, I can simulate a digital input and it is reflected at the Inputs in VISILOGIC.
image.png 

b63231ea-0bee-4b76-bec7-55a095c6d536.png

 
However, it does not work the other way. When you set an output, you can see it on VISILOGIC, but it does not turns ON on the module.
image.png
I believe I am doing something wrong. If you find something, please let me know.
 

Prueba EX-RC1 sin CANBUS.vlp

Link to comment
Share on other sites

Hello Alex. 

Thanks for your response. It doesn´t matter if the project is empty. By forcing outputs, the IOS should work. As I said I have tested before and this is a way to assure communication between the EX-RC1 gateway and the IOs.

The SB you mention should be at 0 and they all are. 

Problem has been solved. It was a matter of firmware. Today I received a remote help with UNITRONICS and they update the firmware, and it works.

It works without any program.

 

Thanks all for the help, and also for your time and effort.

Joaquin

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...